Script 'mail_helper' called by obssrc Hello community, here is the log from the commit of package crmsh for openSUSE:Factory checked in at 2026-09-17 15:25:07 ++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++ Comparing /work/SRC/openSUSE:Factory/crmsh (Old) and /work/SRC/openSUSE:Factory/.crmsh.new.383539 (New) ++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
Package is "crmsh" Thu Sep 17 15:25:07 2026 rev:421 rq:1378564 version:5.1.0+20260917.eab338e3 Changes: -------- --- /work/SRC/openSUSE:Factory/crmsh/crmsh.changes 2026-08-28 19:50:57.584479107 +0200 +++ /work/SRC/openSUSE:Factory/.crmsh.new.383539/crmsh.changes 2026-09-17 15:25:20.643888542 +0200 @@ -1,0 +2,53 @@ +Thu Sep 17 08:34:48 UTC 2026 - [email protected] + +- Update to version 5.1.0+20260917.eab338e3: + * docs(ui_node): document node maintenance behavior + * feat(ui_node): support local-node default and multiple nodes for `node maintenance` + * feat(ui_node): deprecate `node ready` command + * feat(ui_node): add on|off option to `node maintenance` command + +------------------------------------------------------------------- +Wed Sep 16 08:45:51 UTC 2026 - [email protected] + +- Update to version 5.1.0+20260916.8f04e767: + * test(features): should not inherit stdin in feature tests + * fix(sh): ShellUtils.get_stdout_stderr need to handle empty input_s differently to unspecified input_s + * refactor(utils): combine LoggerUtils.confirm into utils.ask (#2196) + * test(sbd): mock time.sleep in _fix_fence_sbd tests + * feat(qdevice): validate QNetd network interface separation from Corosync links (#2184) + * feat(bootstrap): allow specifying default answer in confirm (#2184) + * refactor(bootstrap): rename `Arguments.args` to `Arguments.remaining_args` + * refactor(sbd): avoid passing `diskless_sbd` around with `GlobalVariables` + * refactor(bootstrap): rename memory state-populating helpers to populate_* + * refactor(bootstrap): avoid modifying parsed arguments when determining IP version + * refactor(bootstrap): split Context class into Arguments and GlobalVariables + * style(sbd): docstring should use triple double quotes + * refactor(qdevice): introduce callback for issuing validation messages and overrides + +------------------------------------------------------------------- +Wed Sep 09 09:27:14 UTC 2026 - [email protected] + +- Update to version 5.1.0+20260909.688b0680: + * fix(ui_resource): validate operation and interval in resource trace + * refactor(xmlutil): use crm_mon XML for resource location + * refactor(xmlutil): rename CrmMonXmlParser to CrmMonXMLParser + +------------------------------------------------------------------- +Fri Sep 04 10:57:57 UTC 2026 - [email protected] + +- Update to version 5.1.0+20260904.7193bcdd: + * docs(sbd): document SBD_DELAY_START set to no for bare metal environment + +------------------------------------------------------------------- +Tue Sep 01 09:43:33 UTC 2026 - [email protected] + +- Update to version 5.1.0+20260901.e016e85f: + * feat(report): collect OCFS2 volume details + +------------------------------------------------------------------- +Tue Sep 01 07:55:39 UTC 2026 - [email protected] + +- Update to version 5.1.0+20260901.0bb7784b: + * ci(workflow): fix weekly cache key week number mismatch + +------------------------------------------------------------------- Old: ---- crmsh-5.1.0+20260828.be794583.tar.bz2 New: ---- crmsh-5.1.0+20260917.eab338e3.tar.bz2 ++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++ Other differences: ------------------ ++++++ crmsh.spec ++++++ --- /var/tmp/diff_new_pack.A9ABwj/_old 2026-09-17 15:25:21.708933208 +0200 +++ /var/tmp/diff_new_pack.A9ABwj/_new 2026-09-17 15:25:21.710933292 +0200 @@ -40,7 +40,7 @@ Summary: High Availability cluster command-line interface License: GPL-2.0-or-later Group: %{pkg_group} -Version: 5.1.0+20260828.be794583 +Version: 5.1.0+20260917.eab338e3 Release: 0 URL: http://crmsh.github.io Source0: %{name}-%{version}.tar.bz2 ++++++ _servicedata ++++++ --- /var/tmp/diff_new_pack.A9ABwj/_old 2026-09-17 15:25:21.759935347 +0200 +++ /var/tmp/diff_new_pack.A9ABwj/_new 2026-09-17 15:25:21.764935557 +0200 @@ -9,7 +9,7 @@ </service> <service name="tar_scm"> <param name="url">https://github.com/ClusterLabs/crmsh.git</param> - <param name="changesrevision">902fa683497a797a9c85234fb7130b86a1d5b1be</param> + <param name="changesrevision">eab338e35a2b8bc1bfcbca227231fe3ef4ae9b63</param> </service> </servicedata> (No newline at EOF) ++++++ crmsh-5.1.0+20260828.be794583.tar.bz2 -> crmsh-5.1.0+20260917.eab338e3.tar.bz2 ++++++ ++++ 6473 lines of diff (skipped)
