Script 'mail_helper' called by obssrc
Hello community,

here is the log from the commit of package graphifyy for openSUSE:Factory 
checked in at 2026-10-26 10:04:34
++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
Comparing /work/SRC/openSUSE:Factory/graphifyy (Old)
 and      /work/SRC/openSUSE:Factory/.graphifyy.new.2252680 (New)
++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

Package is "graphifyy"

Mon Oct 26 10:04:34 2026 rev:5 rq:1392610 version:0.9.95

Changes:
--------
--- /work/SRC/openSUSE:Factory/graphifyy/graphifyy.changes      2026-10-20 
12:38:05.302938601 +0200
+++ /work/SRC/openSUSE:Factory/.graphifyy.new.2252680/graphifyy.changes 
2026-10-26 10:05:43.319104377 +0100
@@ -1,0 +2,19 @@
+Sun Oct 25 20:37:16 UTC 2026 - Martin Pluskal <[email protected]>
+
+- Update to version 0.9.95:
+  * 0.9.93: Kotlin typealias, C# delegate, Swift macro, Dart
+    typedef and sibling-module Rust use resolve to declarations;
+    credential redaction on rationale labels; versioned-shebang
+    scripts classified
+  * 0.9.94: URL validation rejects hostless/credential-bearing
+    URLs, Maven POM contributes own dependencies only, T-SQL
+    support and cross-file table-stub folding in SQL pass
+  * 0.9.95: structural YAML extraction (new PyYAML dependency),
+    per-language type-alias nodes, per-overload C# methods,
+    symlink-proof skill-install writes, SSRF multicast block
+  * AST cache schema bumped, so the first build after upgrading
+    re-extracts
+- Require python-PyYAML >= 6.0 (new upstream core dependency)
+  and raise the setuptools floor to >= 83
+
+-------------------------------------------------------------------

Old:
----
  graphify-0.9.92.tar.gz

New:
----
  graphify-0.9.95.tar.gz

++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

Other differences:
------------------
++++++ graphifyy.spec ++++++
--- /var/tmp/diff_new_pack.oiWLiu/_old  2026-10-26 10:05:45.227184364 +0100
+++ /var/tmp/diff_new_pack.oiWLiu/_new  2026-10-26 10:05:45.229184447 +0100
@@ -20,7 +20,7 @@
 # (successor of the python-graphifyy multibuild package).
 %define pythons %{primary_python}
 Name:           graphifyy
-Version:        0.9.92
+Version:        0.9.95
 Release:        0
 Summary:        Code knowledge graph builder and query CLI for AI assistants
 License:        Apache-2.0 AND MIT
@@ -28,8 +28,9 @@
 # PyPI sdist omits tests/fixtures and ARCHITECTURE.md, which %%check needs.
 # Use the GitHub tag archive (same revision as the PyPI release).
 Source:         
https://github.com/Graphify-Labs/graphify/archive/refs/tags/v%{version}.tar.gz#/graphify-%{version}.tar.gz
-# Optional at runtime: nested YAML frontmatter uses PyYAML when present.
-BuildRequires:  %{primary_python}-PyYAML
+# Mandatory since 0.9.95: structural YAML extraction parses .yaml/.yml
+# via yaml.safe_load (upstream pyyaml>=6.0 core dependency).
+BuildRequires:  %{primary_python}-PyYAML >= 6.0
 BuildRequires:  %{primary_python}-mcp >= 1
 BuildRequires:  %{primary_python}-networkx >= 3.4
 BuildRequires:  %{primary_python}-numpy >= 1.21
@@ -39,10 +40,8 @@
 # .robot/.resource extraction parses via robot.api (upstream [robot] extra);
 # absent, those tests skip and only Robot Framework support is lost
 BuildRequires:  %{primary_python}-robotframework >= 4.0
-# Upstream build wants setuptools >= 83, not yet in the tree (has
-# 80.9): keep the satisfiable floor, plain setuptools.build_meta
-# needs nothing newer.
-BuildRequires:  %{primary_python}-setuptools >= 77
+# Upstream build wants setuptools >= 83 (Factory ships 84).
+BuildRequires:  %{primary_python}-setuptools >= 83
 # HTTP MCP tests import starlette; extra floor is 1.3.1 (CVE-2026-48818 /
 # CVE-2026-54283)
 BuildRequires:  %{primary_python}-starlette >= 1.3.1
@@ -109,6 +108,7 @@
 BuildRequires:  tree-sitter-zig
 Requires:       %{primary_python}-networkx >= 3.4
 Requires:       %{primary_python}-numpy >= 1.21
+Requires:       %{primary_python}-PyYAML >= 6.0
 Requires:       %{primary_python}-rapidfuzz >= 3.0
 Recommends:     %{primary_python}-robotframework >= 4.0
 Recommends:     %{primary_python}-tree-sitter >= 0.25

++++++ graphify-0.9.92.tar.gz -> graphify-0.9.95.tar.gz ++++++
/work/SRC/openSUSE:Factory/graphifyy/graphify-0.9.92.tar.gz 
/work/SRC/openSUSE:Factory/.graphifyy.new.2252680/graphify-0.9.95.tar.gz 
differ: char 34, line 2

Reply via email to