Script 'mail_helper' called by obssrc Hello community, here is the log from the commit of package wmime for openSUSE:Factory checked in at 2026-10-29 20:05:20 ++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++ Comparing /work/SRC/openSUSE:Factory/wmime (Old) and /work/SRC/openSUSE:Factory/.wmime.new.1255 (New) ++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
Package is "wmime" Thu Oct 29 20:05:20 2026 rev:3 rq:1393689 version:1.2.0 Changes: -------- --- /work/SRC/openSUSE:Factory/wmime/wmime.changes 2025-07-25 17:06:12.031468935 +0200 +++ /work/SRC/openSUSE:Factory/.wmime.new.1255/wmime.changes 2026-10-29 20:05:43.719691237 +0100 @@ -1,0 +2,19 @@ +Tue Oct 27 16:02:43 UTC 2026 - Jan Engelhardt <[email protected]> + +- Update to release 1.2.0 + * Removed extraneous `const` qualifiers on return types that + prevented feeding generate() return values to another function + as movable rvalues. + * Over-encoding ASCII words in RFC 6532 mode is avoided. + * The Date: line parser is now in line with RFC 5322, abolishing + recognition for single-letter time zones previously availablein + RFC 822. + * Added support for IMAP ID extension. + * Added support for Cygwin. + * Header folding is now in accordance with RFC 5322/2047. + * In e.g. To: address lists, '(' and '<' were erroneously parsed + as comment and start of address even when they appeared in a + quoted display name, which has been fixed. +- Add i387.patch + +------------------------------------------------------------------- Old: ---- debian.libwmime2.install wmime-1.1.0.tar.asc wmime-1.1.0.tar.zst New: ---- debian.libwmime3.install i387.patch wmime-1.2.0.tar.asc wmime-1.2.0.tar.zst ----------(New B)---------- New: quoted display name, which has been fixed. - Add i387.patch ----------(New E)---------- ++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++ Other differences: ------------------ ++++++ wmime.spec ++++++ --- /var/tmp/diff_new_pack.K0rWZo/_old 2026-10-29 20:05:46.362802019 +0100 +++ /var/tmp/diff_new_pack.K0rWZo/_new 2026-10-29 20:05:46.364802103 +0100 @@ -1,7 +1,7 @@ # -# spec file for package libvmime +# spec file for package wmime # -# Copyright (c) 2025 SUSE LLC +# Copyright (c) 2026 SUSE LLC and contributors # # All modifications and additions to the file contributed by third parties # remain the property of their copyright owners, unless otherwise agreed @@ -16,31 +16,41 @@ # +%if 0%{?sle_version} && 0%{?sle_version} < 160000 +%bcond_with gsasl +%else +%bcond_without gsasl +%endif + Name: wmime -%define lname libwmime2 -Version: 1.1.0 +%define lname libwmime3 +Version: 1.2.0 Release: 0 Summary: Library for working with RFC 5322, MIME messages and IMAP/POP/SMTP License: GPL-3.0-or-later Group: Development/Libraries/C and C++ URL: https://github.com/grommunio/wmime/ - Source: https://github.com/grommunio/wmime/releases/download/wmime-%version/wmime-%version.tar.zst Source2: https://github.com/grommunio/wmime/releases/download/wmime-%version/wmime-%version.tar.asc Patch1: nodate.patch +Patch2: i387.patch BuildRequires: cmake >= 2.8.3 BuildRequires: gcc-c++ +%if 0%{?suse_version} >= 1600 +BuildRequires: glibc-gconv-modules-extra +%endif %if 0%{?rhel} || 0%{?fedora_version} BuildRequires: gnutls-devel %else BuildRequires: libgnutls-devel %endif -%if !0%{?sle_version} +%if %{with gsasl} BuildRequires: libgsasl-devel %endif BuildRequires: openssl-devel BuildRequires: pkg-config BuildRequires: zstd +BuildRequires: pkgconfig(cppunit) %if 0%{?with_pdf} BuildRequires: ImageMagick BuildRequires: doxygen @@ -79,8 +89,8 @@ Summary: Development files for vmime, an e-mail message library Group: Development/Libraries/C and C++ Requires: %lname = %version -Obsoletes: libvmime-devel < 0.9.2+git204 -Provides: libvmime-devel = 0.9.2+git204 +Obsoletes: libvmime-devel < 0.9.2+git224 +Provides: libvmime-devel = 0.9.2+git224 %description devel VMime is a C++ class library for working with RFC5322 and @@ -94,20 +104,16 @@ %build %if 0%{?with_pdf} -pushd doc/book/ +cd doc/book/ make book_pdf -popd +cd - %endif %cmake \ - -DCMAKE_INSTALL_PREFIX:PATH="%_prefix" \ - -DINCLUDE_INSTALL_DIR:PATH="%_includedir" \ - -DSYSCONF_INSTALL_DIR:PATH="%_sysconfdir" \ - -DSHARE_INSTALL_PREFIX:PATH="%_datadir" \ -DCMAKE_INSTALL_LIBDIR:PATH="%_libdir" \ -DVMIME_SENDMAIL_PATH:STRING="%_sbindir/sendmail" \ -DVMIME_BUILD_SAMPLES:BOOL=OFF \ -%if 0%{?sle_version} +%if %{without gsasl} -DVMIME_HAVE_SASL_SUPPORT:BOOL=OFF \ %endif -DVMIME_HAVE_TLS_SUPPORT:BOOL=ON \ @@ -129,11 +135,28 @@ %cmake_install find "$b" -type f -name "*.la" -delete +%check +# rebuild to workaround https://github.com/kisli/vmime/issues/369 +%define __builddir testbuild +orig="$PWD" +%cmake \ +%if %{without gsasl} + -DVMIME_HAVE_SASL_SUPPORT:BOOL=OFF \ +%endif + -DVMIME_SENDMAIL_PATH:STRING=/bin/true \ + -DVMIME_BUILD_DOCUMENTATION:BOOL=OFF \ + -DVMIME_BUILD_SAMPLES:BOOL=OFF \ + -DVMIME_BUILD_TESTS:BOOL=ON \ + -DBUILD_SHARED_LIBS:BOOL=OFF +%cmake_build +cd "$orig" +%ctest + %ldconfig_scriptlets -n %lname %files -n %lname %license COPYING -%_libdir/libwmime.so.2* +%_libdir/libwmime.so.* %files devel %_includedir/vmime ++++++ _scmsync.obsinfo ++++++ --- /var/tmp/diff_new_pack.K0rWZo/_old 2026-10-29 20:05:46.473806672 +0100 +++ /var/tmp/diff_new_pack.K0rWZo/_new 2026-10-29 20:05:46.479806923 +0100 @@ -1,4 +1,4 @@ -mtime: 1753398758 -commit: e9c0221f8d86012426ce089be9bfe5f1ca6882511e242f8bb59a8a118eb47f7f +mtime: 1793281385 +commit: 8e6f8bd839ba43e02c3e1e47c95f833ffe35a185de2c77452d7a82cdddec9438 url: https://src.opensuse.org/jengelh/wmime ++++++ debian.changelog ++++++ --- /var/tmp/diff_new_pack.K0rWZo/_old 2026-10-29 20:05:46.557810193 +0100 +++ /var/tmp/diff_new_pack.K0rWZo/_new 2026-10-29 20:05:46.571810780 +0100 @@ -1,4 +1,4 @@ -wmime (1.0.0) unstable; urgency=low +wmime (1.2.0) unstable; urgency=low * Initial package. ++++++ debian.control ++++++ --- /var/tmp/diff_new_pack.K0rWZo/_old 2026-10-29 20:05:46.651814133 +0100 +++ /var/tmp/diff_new_pack.K0rWZo/_new 2026-10-29 20:05:46.664814678 +0100 @@ -5,7 +5,7 @@ Standards-Version: 4.5.0 Build-Depends: debhelper-compat (= 12) -Package: libwmime2 +Package: libwmime3 Architecture: any Depends: ${misc:Depends}, ${shlibs:Depends} Description: Library for working with MIME messages and IMAP/POP/SMTP @@ -13,9 +13,9 @@ Package: wmime-dev Architecture: any -Breaks: libvmime-dev (< 0.9.2.204) -Replaces: libvmime-dev (< 0.9.2.204) -Depends: ${misc:Depends}, libwmime2 (= ${binary:Version}), +Breaks: libvmime-dev (< 0.9.2.224) +Replaces: libvmime-dev (< 0.9.2.224) +Depends: ${misc:Depends}, libwmime3 (= ${binary:Version}), libgsasl-dev | libgsasl7-dev, libgnutls28-dev Description: Development files for vmime, an e-mail message library . ++++++ debian.libwmime2.install -> debian.libwmime3.install ++++++ --- /work/SRC/openSUSE:Factory/wmime/debian.libwmime2.install 2025-01-22 16:32:08.391492719 +0100 +++ /work/SRC/openSUSE:Factory/.wmime.new.1255/debian.libwmime3.install 2026-10-29 20:05:43.610686669 +0100 @@ -1 +1 @@ -usr/lib/*/libwmime*.so.2* +usr/lib/*/libwmime*.so.* ++++++ i387.patch ++++++ >From 7e053d277ae0c738633dc226752a04864e27966a Mon Sep 17 00:00:00 2001 From: Jan Engelhardt <[email protected]> Date: Thu, 29 Oct 2026 14:07:17 +0100 Subject: [PATCH] vmime: quantize ascii percentage count in guessBestEncoding References: https://github.com/kisli/vmime/pull/373 Workaround testsuite failures when the i387 FPU is used. --- src/vmime/text.cpp | 6 +++--- src/vmime/wordEncoder.cpp | 6 +++--- 2 files changed, 6 insertions(+), 6 deletions(-) diff --git a/src/vmime/text.cpp b/src/vmime/text.cpp index 2c14110b..12d2916a 100644 --- a/src/vmime/text.cpp +++ b/src/vmime/text.cpp @@ -269,7 +269,7 @@ shared_ptr <text> text::newFromString(const string& in, const charset& ch) { void text::createFromString(const string& in, const charset& ch) { - double asciiPercent = 0; + unsigned int asciiPercent = 0; removeAllWords(); @@ -282,12 +282,12 @@ void text::createFromString(const string& in, const charset& ch) { if (!alwaysEncode) { const auto asciiCount = utility::stringUtils::countASCIIchars(in.begin(), in.end()); - asciiPercent = in.length() == 0 ? 1 : static_cast<double>(asciiCount) / static_cast<double>(in.length()); + asciiPercent = in.length() == 0 ? 100 : static_cast<double>(asciiCount) * 100 / static_cast<double>(in.length()); } // Cf. wordEncoder::guessBestEncoding for details - if (alwaysEncode || asciiPercent < 0.60) { // less than 60% ASCII chars + if (alwaysEncode || asciiPercent < 60) { // less than 60% ASCII chars appendWord(make_shared <word>(in, ch)); return; diff --git a/src/vmime/wordEncoder.cpp b/src/vmime/wordEncoder.cpp index 404a57b4..17488046 100644 --- a/src/vmime/wordEncoder.cpp +++ b/src/vmime/wordEncoder.cpp @@ -308,10 +308,10 @@ wordEncoder::Encoding wordEncoder::guessBestEncoding( const size_t asciiCount = utility::stringUtils::countASCIIchars(buffer.begin(), buffer.end()); - const double asciiPercent = - buffer.length() == 0 ? 1 : static_cast<double>(asciiCount) / static_cast<double>(buffer.length()); + const unsigned int asciiPercent = + buffer.length() == 0 ? 100 : static_cast<double>(asciiCount) * 100 / static_cast<double>(buffer.length()); - if (asciiPercent < 0.60) { + if (asciiPercent < 60) { return ENCODING_B64; } else { return ENCODING_QP; -- 2.56.0 ++++++ wmime-1.1.0.tar.zst -> wmime-1.2.0.tar.zst ++++++ ++++ 9498 lines of diff (skipped) ++++++ wmime.dsc ++++++ --- /var/tmp/diff_new_pack.K0rWZo/_old 2026-10-29 20:05:47.452847707 +0100 +++ /var/tmp/diff_new_pack.K0rWZo/_new 2026-10-29 20:05:47.459848000 +0100 @@ -1,7 +1,7 @@ Format: 1.0 Source: wmime Architecture: any -Version: 1.0.0 +Version: 1.2.0 DEBTRANSFORM-RELEASE: 1 Maintainer: openSUSE <[email protected]> Homepage: https://opensuse.org/
