[
https://issues.apache.org/jira/browse/AIRFLOW-2462?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16499402#comment-16499402
]
ASF subversion and git services commented on AIRFLOW-2462:
----------------------------------------------------------
Commit 29dbedfd0a49c54eaf388ff940ec7cfe4a6e1f7f in incubator-airflow's branch
refs/heads/master from [~noremac201]
[ https://git-wip-us.apache.org/repos/asf?p=incubator-airflow.git;h=29dbedf ]
[AIRFLOW-2462] Change PasswordUser setter to correct syntax
Closes #3415 from Noremac201/setterFix
> airflow.contrib.auth.backends.password_auth.PasswordUser exists bug
> -------------------------------------------------------------------
>
> Key: AIRFLOW-2462
> URL: https://issues.apache.org/jira/browse/AIRFLOW-2462
> Project: Apache Airflow
> Issue Type: Bug
> Components: authentication, contrib
> Affects Versions: 1.9.0
> Reporter: froginwell
> Priority: Blocker
>
> PasswordUser
> {quote}
> @password.setter
> def _set_password(self, plaintext):
> self._password = generate_password_hash(plaintext, 12)
> if PY3:
> self._password = str(self._password, 'utf-8')
> {quote}
> _set_password should be renamed as password.
--
This message was sent by Atlassian JIRA
(v7.6.3#76005)