This is an automated email from the ASF dual-hosted git repository.

wesm pushed a commit to branch master
in repository https://gitbox.apache.org/repos/asf/arrow.git


The following commit(s) were added to refs/heads/master by this push:
     new c2865d0  ARROW-2093: [Python] Do not install PyTorch in Travis CI
c2865d0 is described below

commit c2865d064cd1d7622ca33d77a6a683dfb2903e38
Author: Wes McKinney <wes.mckin...@twosigma.com>
AuthorDate: Thu Feb 22 19:53:33 2018 -0500

    ARROW-2093: [Python] Do not install PyTorch in Travis CI
    
    Author: Wes McKinney <wes.mckin...@twosigma.com>
    
    Closes #1637 from wesm/ARROW-2093 and squashes the following commits:
    
    e3040a99 <Wes McKinney> Do not install PyTorch in Travis CI
---
 ci/travis_script_python.sh | 13 ++++++++-----
 1 file changed, 8 insertions(+), 5 deletions(-)

diff --git a/ci/travis_script_python.sh b/ci/travis_script_python.sh
index a487da5..9ed5825 100755
--- a/ci/travis_script_python.sh
+++ b/ci/travis_script_python.sh
@@ -43,11 +43,14 @@ conda install -y -q pip \
       pandas \
       cython
 
-if [ "$PYTHON_VERSION" != "2.7" ] || [ $TRAVIS_OS_NAME != "osx" ]; then
-  # Install pytorch for torch tensor conversion tests
-  # PyTorch seems to be broken on Python 2.7 on macOS so we skip it
-  conda install -y -q pytorch torchvision -c soumith
-fi
+# ARROW-2093: PyTorch increases the size of our conda dependency stack
+# significantly, and so we have disabled these tests in Travis CI for now
+
+# if [ "$PYTHON_VERSION" != "2.7" ] || [ $TRAVIS_OS_NAME != "osx" ]; then
+#   # Install pytorch for torch tensor conversion tests
+#   # PyTorch seems to be broken on Python 2.7 on macOS so we skip it
+#   conda install -y -q pytorch torchvision -c soumith
+# fi
 
 # Build C++ libraries
 mkdir -p $ARROW_CPP_BUILD_DIR

-- 
To stop receiving notification emails like this one, please contact
w...@apache.org.

Reply via email to