This is an automated email from the ASF dual-hosted git repository.

uwe pushed a commit to branch master
in repository https://gitbox.apache.org/repos/asf/arrow.git


The following commit(s) were added to refs/heads/master by this push:
     new 02b0c72  ARROW-2325: [Python] Update setup.py to use Markdown project 
description
02b0c72 is described below

commit 02b0c723401a9d96866668d9c115e557834f6b94
Author: Alex <a...@unexpectedeof.net>
AuthorDate: Thu Apr 5 09:16:36 2018 +0200

    ARROW-2325: [Python] Update setup.py to use Markdown project description
    
    Any thoughts on the best way to make sure the `pip` upload uses 
`twine>=1.11.0` and `setuptools>=38.6.0`? I don't see a reference to the twine 
version in 
https://github.com/apache/arrow/blob/master/dev/release/RELEASE_MANAGEMENT.md 
but maybe adding a note? Or maybe it should be documented and part of the 
packaging discussion?
    
    Author: Alex <a...@unexpectedeof.net>
    
    Closes #1811 from AlexHagerman/setuppy_longdescription and squashes the 
following commits:
    
    54d1788 <Alex> Updated release documentation to reflect Python twine and 
setuptools requirements.
    264cdc8 <Alex> Removing duplicate import
    a3b260c <Alex> Updated long_description to be based on README.md
    c80bcec <Alex> Updated setup.py per Arrow-2325
---
 dev/release/RELEASE_MANAGEMENT.md | 12 +++++++++---
 python/setup.py                   |  8 +++-----
 2 files changed, 12 insertions(+), 8 deletions(-)

diff --git a/dev/release/RELEASE_MANAGEMENT.md 
b/dev/release/RELEASE_MANAGEMENT.md
index 06340ab..801072d 100644
--- a/dev/release/RELEASE_MANAGEMENT.md
+++ b/dev/release/RELEASE_MANAGEMENT.md
@@ -157,9 +157,15 @@ The pip binary packages (called "wheels") are generated 
from the
 * Download all wheel and tar.gz files from the new BinTray package version
   ([example][4])
 
-Now, you can finally upload the wheels to PyPI using the `twine` CLI tool. You
-must be permissioned on PyPI to upload here; ask Wes McKinney or Uwe Korn if
-you need help with this.
+
+Now, you can finally upload the wheels to PyPI using the `twine` CLI tool. 
+Please make sure you use `twine>=1.11.0`. This supports the markdown 
+long description in setup.py which also requires `setuptools>=38.6.0`. 
+`setuptools` is handled in previous steps by the `.travis.yml` and 
+`appveyor.yml` build configurations. 
+
+You must be permissioned on PyPI to upload here; ask Wes McKinney or Uwe Korn 
+if you need help with this.
 
 #### Updating conda packages
 
diff --git a/python/setup.py b/python/setup.py
index 91e0bb9..61c9a75 100644
--- a/python/setup.py
+++ b/python/setup.py
@@ -433,11 +433,8 @@ if not os.path.exists('../.git') and 
os.path.exists('../java/pom.xml'):
     os.environ["SETUPTOOLS_SCM_PRETEND_VERSION"] = version_tag.text.replace(
         "-SNAPSHOT", "a0")
 
-long_description = """Apache Arrow is a columnar in-memory analytics layer
-designed to accelerate big data. It houses a set of canonical in-memory
-representations of flat and hierarchical data along with multiple
-language-bindings for structure manipulation. It also provides IPC
-and common algorithm implementations."""
+with open('README.md') as f:
+    long_description = f.read()
 
 
 class BinaryDistribution(Distribution):
@@ -494,6 +491,7 @@ setup(
     tests_require=['pytest', 'pandas'],
     description="Python library for Apache Arrow",
     long_description=long_description,
+    long_description_content_type="text/markdown",
     classifiers=[
         'License :: OSI Approved :: Apache Software License',
         'Programming Language :: Python :: 2.7',

-- 
To stop receiving notification emails like this one, please contact
u...@apache.org.

Reply via email to