[ 
https://issues.apache.org/jira/browse/BEAM-2671?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16115339#comment-16115339
 ] 

Aviem Zur edited comment on BEAM-2671 at 8/5/17 8:54 AM:
---------------------------------------------------------

If we want streaming to be working in Spark runner in 2.1.0 we should fix this 
for 2.1.0
This was the goal of https://github.com/apache/beam/pull/3343
There has been regression since.

If there is a different, more important goal for this version, then we could 
release yet another version with streaming not working in Spark runner.


was (Author: aviemzur):
If we want streaming to be working in Spark runner in 2.1.0 we should fix this 
for 2.1.0
This was the goal of https://github.com/apache/beam/pull/3343
There has been regression since.

If there is a different, more important goal for this version, then we could 
release yet another version with streaming not working in spark runner.

> CreateStreamTest.testFirstElementLate validatesRunner test fails on Spark 
> runner
> --------------------------------------------------------------------------------
>
>                 Key: BEAM-2671
>                 URL: https://issues.apache.org/jira/browse/BEAM-2671
>             Project: Beam
>          Issue Type: Bug
>          Components: runner-spark
>            Reporter: Etienne Chauchot
>            Assignee: Jean-Baptiste Onofré
>             Fix For: 2.1.0
>
>
> Error message:
> Flatten.Iterables/FlattenIterables/FlatMap/ParMultiDo(Anonymous).out0: 
> Expected: iterable over [] in any order
>      but: Not matched: "late"



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Reply via email to