[ 
https://issues.apache.org/jira/browse/BEAM-3950?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16426222#comment-16426222
 ] 

Ahmet Altay commented on BEAM-3950:
-----------------------------------

I assume that the SDK will know whether the default container accepts wheel 
files or not. Based on that it can choose a sane default. If custom containers 
are used, it could be up to the user to pick the right version of the SDK 
(including the wheel files).

It is also fine to stage both tar file and whl file, but if both SDK and user 
has collectively no idea about the target platform than all variations of the 
wheel files need to be staged.

> Dataflow Runner should supply a wheel version of Python SDK if it is available
> ------------------------------------------------------------------------------
>
>                 Key: BEAM-3950
>                 URL: https://issues.apache.org/jira/browse/BEAM-3950
>             Project: Beam
>          Issue Type: Improvement
>          Components: runner-dataflow, sdk-py-core
>            Reporter: Valentyn Tymofieiev
>            Assignee: Valentyn Tymofieiev
>            Priority: Major
>




--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Reply via email to