Reuven Lax commented on BEAM-4083:

TypeName is not itself a type. FieldType is the actual "type" - TypeName simply 
segregates classes of types.

> TypeName should be a proper algebraic type, and probably just called BeamType
> -----------------------------------------------------------------------------
>                 Key: BEAM-4083
>                 URL: https://issues.apache.org/jira/browse/BEAM-4083
>             Project: Beam
>          Issue Type: Sub-task
>          Components: sdk-java-core
>            Reporter: Kenneth Knowles
>            Priority: Major
> TypeName mixes atomic types and type constructors. Or, equivalently, it does 
> not distinguish by arity the type constructors. It would be best to make this 
> an ADT.

This message was sent by Atlassian JIRA

Reply via email to