Ahmet Altay resolved BEAM-517.
       Resolution: Fixed
    Fix Version/s: Not applicable

> Check versions of pip and cython
> --------------------------------
>                 Key: BEAM-517
>                 URL: https://issues.apache.org/jira/browse/BEAM-517
>             Project: Beam
>          Issue Type: Improvement
>          Components: sdk-py
>            Reporter: Ahmet Altay
>            Priority: Minor
>              Labels: starter
>             Fix For: Not applicable
> Python SDK depends on pip and cython however it does not check the versions 
> of these.
> Some of the pip flags does not exist in older versions:
> https://github.com/GoogleCloudPlatform/DataflowPythonSDK/issues/28#issuecomment-236382953
> (Note: Even though the above issue was reported by the user in a different 
> repo it is related to the apache beam sdk)
> Similarly with cython, SDK supports running with or without Cython. Because 
> of that reason it is not list it as a requirement in the setup.py file. 
> However, with an old version of cython SDK might fail.
> To avoid the above problem: In the SDK check the version of these packages 
> and show a warning to upgrade.

This message was sent by Atlassian JIRA

Reply via email to