Repository: calcite
Updated Branches:
  refs/heads/master a838a73c9 -> 502c10847


[CALCITE-2237] Upgrade Maven Surefire plugin to 2.21.0 (Kevin Risden)

Fixes NPE when using Maven Surefire plugin 2.20.1 on JDK 10.
See [SUREFIRE-1439] and [MPOM-184] for details.

Close apache/calcite#656


Project: http://git-wip-us.apache.org/repos/asf/calcite/repo
Commit: http://git-wip-us.apache.org/repos/asf/calcite/commit/000622da
Tree: http://git-wip-us.apache.org/repos/asf/calcite/tree/000622da
Diff: http://git-wip-us.apache.org/repos/asf/calcite/diff/000622da

Branch: refs/heads/master
Commit: 000622daf9af011b88022b4679dd08c7d09f1475
Parents: a838a73
Author: Kevin Risden <kris...@apache.org>
Authored: Mon Apr 2 22:52:41 2018 -0500
Committer: Julian Hyde <jh...@apache.org>
Committed: Tue Apr 10 18:04:04 2018 -0700

----------------------------------------------------------------------
 pom.xml | 5 ++++-
 1 file changed, 4 insertions(+), 1 deletion(-)
----------------------------------------------------------------------


http://git-wip-us.apache.org/repos/asf/calcite/blob/000622da/pom.xml
----------------------------------------------------------------------
diff --git a/pom.xml b/pom.xml
index 957e853..105ae4a 100644
--- a/pom.xml
+++ b/pom.xml
@@ -104,10 +104,12 @@ limitations under the License.
     <maven-checkstyle-plugin.version>3.0.0</maven-checkstyle-plugin.version>
     <maven-dependency-plugin.version>2.10</maven-dependency-plugin.version>
     <maven-enforcer-plugin.version>3.0.0-M1</maven-enforcer-plugin.version>
-    <!-- Apache 19 has 2.10.4, but need 3.0.0 for [LANG-365]. -->
+    <!-- Apache 19 has 2.10.4, but need 3.0.0 for [LANG-1365]. -->
     <maven-javadoc-plugin.version>3.0.0</maven-javadoc-plugin.version>
     <maven-scm-provider.version>1.9.4</maven-scm-provider.version>
     <maven-shade-plugin.version>2.1</maven-shade-plugin.version>
+    <!-- Apache 19 has 2.20.1, but need 2.21.0+ for [MPOM-184] -->
+    <maven-surefire-plugin.version>2.21.0</maven-surefire-plugin.version>
     <mockito.version>2.5.5</mockito.version>
     <mongo-java-driver.version>3.5.0</mongo-java-driver.version>
     <mysql-driver.version>5.1.20</mysql-driver.version>
@@ -855,6 +857,7 @@ limitations under the License.
         <plugin>
           <groupId>org.apache.maven.plugins</groupId>
           <artifactId>maven-surefire-plugin</artifactId>
+          <version>${maven-surefire-plugin.version}</version>
           <configuration>
             <threadCount>1</threadCount>
             <perCoreThreadCount>true</perCoreThreadCount>

Reply via email to