[ 
https://issues.apache.org/jira/browse/CASSANDRA-9448?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

Sylvain Lebresne reopened CASSANDRA-9448:
-----------------------------------------

Sorry to come a little late on that one, but are we sure we want to rename the 
rowCache metrics to paritionCache*, knowing that:
# it's still called the row_cache a little bit everywhere, including in 
user-facing places like the yaml. I'm not sure the inconsistency brings clarity 
in particular and it feels that if we want to rename this we should rename it 
everywhere or nowhere.
# that cache actually still store rows strictly speaking, and so while the 
meaning of "row" has changed, it's not really invalid to keep the "rowCache" 
name, and to the best of my knowledge that's why we haven't done that renaming 
before. Note that I don't care too much if we want to rename it, it just feel 
unnecessary in that case and so simpler not to do so, but I think we should be 
somewhat consistent. 

> Metrics should use up to date nomenclature
> ------------------------------------------
>
>                 Key: CASSANDRA-9448
>                 URL: https://issues.apache.org/jira/browse/CASSANDRA-9448
>             Project: Cassandra
>          Issue Type: Improvement
>          Components: Tools
>            Reporter: Sam Tunnicliffe
>            Assignee: Stefania
>              Labels: docs-impacting, jmx
>             Fix For: 3.0 beta 1
>
>
> There are a number of exposed metrics that currently are named using the old 
> nomenclature of columnfamily and rows (meaning partitions).
> It would be good to audit all metrics and update any names to match what they 
> actually represent; we should probably do that in a single sweep to avoid a 
> confusing mixture of old and new terminology. 
> As we'd need to do this in a major release, I've initially set the fixver for 
> 3.0 beta1.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Reply via email to