[ 
https://issues.apache.org/jira/browse/CASSANDRA-10158?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

Sylvain Lebresne updated CASSANDRA-10158:
-----------------------------------------
    Assignee:     (was: Stefania)

> Rationalize implementations of DataInputPlus and DataOutputPlus
> ---------------------------------------------------------------
>
>                 Key: CASSANDRA-10158
>                 URL: https://issues.apache.org/jira/browse/CASSANDRA-10158
>             Project: Cassandra
>          Issue Type: Improvement
>            Reporter: Stefania
>             Fix For: 3.x
>
>
> Following CASSANDRA-8630, we can further improve implementations of 
> {{DataInputPlus}} and {{DataOutputPlus}} as follows:
> * In {{MmappedRegions}}, compact the mmap ranges, at least on the final 
> opening of the file
> * Use the mmap extension logic for compressed files
> * Consider renaming classes to more appropriate names, moving them in their 
> own package and making their relations more simply defined.
> * Consider unifying {{ChecksummedDataInput}} and 
> {{ChecksummedRandomAccessReader}}.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Reply via email to