Achmad Nasirudin Sandi edited comment on CASSANDRA-12790 at 10/14/16 8:15 AM:

It is required by {{metrics-influxdb-1.1.7.jar}}. I tested by inserting some 
record and did SELECT query. It is fine so far. Currently we need ver 3.0.X to 
maintain compatibility against [Spark-Cassandra 

was (Author: achmadns):
It is required by {{metrics-influxdb-1.1.7.jar}}. I tested by inserting some 
record and did SELECT query. It is fine so far.

> Support InfluxDb metrics reporter config
> ----------------------------------------
>                 Key: CASSANDRA-12790
>                 URL: https://issues.apache.org/jira/browse/CASSANDRA-12790
>             Project: Cassandra
>          Issue Type: Improvement
>          Components: Configuration, Packaging
>         Environment: Ubuntu 14.04
> Oracle Java 1.8.0_65
> Cassandra 3.0.9
>            Reporter: Achmad Nasirudin Sandi
>            Priority: Minor
>              Labels: easyfix, easytest, newbie
>         Attachments: metrics-reporter-config-influx.yaml
> InfluxDb is a great tool for storing metrics. The main advantage over 
> graphite protocol is its tag mechanism that allows host info to be excluded 
> from metric name.
> I managed to send metrics into InfluxDb by putting 
> {{metrics-influxdb-1.1.7.jar}} into {{lib}} folder and replacing these 
> dependencies jar:
> {code}
> commons-codec-1.2.jar -> commons-codec-1.9.jar
> reporter-config3-3.0.0.jar -> reporter-config3-3.0.3.jar
> reporter-config-base-3.0.0.jar -> reporter-config-base-3.0.3.jar
> {code}
> Although it seems that dropwizard team is working on official [package for 
> InfluxDb|https://github.com/dropwizard/metrics/tree/4.0-development], it 
> would be great it those libs are available in default distribution by 
> upgrading {{commons-codec}} and {{metrics}} dependencies. I was wondering 
> what effect are there to Cassandra functionality. Where can I help?
> Attached file is my configuration example.

This message was sent by Atlassian JIRA

Reply via email to