[
https://issues.apache.org/jira/browse/CASSANDRA-2272?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]
Matthew F. Dennis updated CASSANDRA-2272:
-----------------------------------------
Attachment: 2272_trunk_v4.txt
attached v4 patch:
1) prefers explicit [key|row] cache objects that extend AutoSavingCache in
preference to branching on CacheType (e.g. "if (cacheType == blah)")
2) minor formatting changes in generic declarations
3) minor name changes
+1 otherwise
> Refactor Key and Row caches handling code
> ------------------------------------------
>
> Key: CASSANDRA-2272
> URL: https://issues.apache.org/jira/browse/CASSANDRA-2272
> Project: Cassandra
> Issue Type: Improvement
> Reporter: Sylvain Lebresne
> Assignee: Sylvain Lebresne
> Priority: Minor
> Fix For: 0.8
>
> Attachments: 0001-Refactor-key-and-row-cache-handling-code-v2.patch,
> 0001-Refactor-key-and-row-cache-handling-code-v3.patch,
> 0001-Refactor-key-and-row-cache-handling-code.patch, 2272_trunk_v4.txt
>
> Original Estimate: 4h
> Remaining Estimate: 4h
>
> The code related to key and row caches has a bunch of code duplication. It's
> moreover a bit scattered, the caches are in SSTableTracker but the scheduled
> task to save them are in CFStore. And having the caches in SSTableTracker is
> not very logic, for row cache at least, since it does not only concern the
> sstables. Proposed patch refactor this to avoid the duplication and put all
> the cache handling code in one place.
--
This message is automatically generated by JIRA.
For more information on JIRA, see: http://www.atlassian.com/software/jira