[ 
https://issues.apache.org/jira/browse/CASSANDRA-13976?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16273727#comment-16273727
 ] 

Jon Haddad edited comment on CASSANDRA-13976 at 12/1/17 12:49 AM:
------------------------------------------------------------------

I've thought about this a bit more, and I think across the board we should be 
using duration types and get rid of the _ms label altogether.

It's WAY more readable and friendly to be able to do:

{code}
max_hint_window = 3h
{code}

Regarding nodetool, it would report back whatever duration labeled setting was 
in there using "ms" if the old _ms value was provided.  Internally, it would 
convert everything to ms, leaving the current code in place.


was (Author: rustyrazorblade):
I've thought about this a bit more, and I think across the board we should be 
using duration types and get rid of the _ms label altogether.

It's WAY more readable and friendly to be able to do:

{code}
max_hint_window = 3h
{code}

Regarding nodetool, it would report back whatever setting was in there.  
Internally, it would convert everything to ms, leaving the current code in 
place.

> introduce max_hint_window_in_min, deprecate max_hint_window_in_ms
> -----------------------------------------------------------------
>
>                 Key: CASSANDRA-13976
>                 URL: https://issues.apache.org/jira/browse/CASSANDRA-13976
>             Project: Cassandra
>          Issue Type: Improvement
>            Reporter: Jon Haddad
>            Assignee: Kirk True
>            Priority: Minor
>              Labels: lhf
>             Fix For: 4.0
>
>
> Milliseconds is unnecessarily precise.  At most, minutes would be used.  
> Config in 4.0 should default to a minute granularity, but if the 
> max_hint_window_in_min isn't set should fall back on max_hint_window_in_ms 
> and emit a warning.
> max_hint_window_in_min: 180 # new default, still at 3 hours.



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

---------------------------------------------------------------------
To unsubscribe, e-mail: commits-unsubscr...@cassandra.apache.org
For additional commands, e-mail: commits-h...@cassandra.apache.org

Reply via email to