[
https://issues.apache.org/jira/browse/CASSANDRA-9067?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16326721#comment-16326721
]
Jay Zhuang commented on CASSANDRA-9067:
---------------------------------------
Here is the patch, please review:
| Branch | uTest |
| [9067|https://github.com/cooldoger/cassandra/tree/9067] |
[!https://circleci.com/gh/cooldoger/cassandra/tree/9067.svg?style=svg!|https://circleci.com/gh/cooldoger/cassandra/tree/9067]
|
Here is the microbench test result (Score number is the running time, smaller
is better):
{noformat}
[java] Benchmark (numElemsInK)
(oldBfFormat) Mode Cnt Score Error Units
[java] BloomFilterSerializerBench.serializationTest 1
true avgt 4 143.170 ? 35.566 us/op
[java] BloomFilterSerializerBench.serializationTest 1
false avgt 4 95.692 ? 61.473 us/op
[java] BloomFilterSerializerBench.serializationTest 10
true avgt 4 662.022 ? 202.386 us/op
[java] BloomFilterSerializerBench.serializationTest 10
false avgt 4 186.326 ? 87.105 us/op
[java] BloomFilterSerializerBench.serializationTest 100
true avgt 4 6312.909 ? 2090.136 us/op
[java] BloomFilterSerializerBench.serializationTest 100
false avgt 4 1125.158 ? 553.381 us/op
[java] BloomFilterSerializerBench.serializationTest 1024
true avgt 4 60436.370 ? 16174.150 us/op
[java] BloomFilterSerializerBench.serializationTest 1024
false avgt 4 10781.518 ? 6975.222 us/op
{noformat}
> BloomFilter serialization format should not change byte ordering
> ----------------------------------------------------------------
>
> Key: CASSANDRA-9067
> URL: https://issues.apache.org/jira/browse/CASSANDRA-9067
> Project: Cassandra
> Issue Type: Improvement
> Reporter: Benedict
> Assignee: Jay Zhuang
> Priority: Minor
> Fix For: 4.x
>
>
> As a follow-up to CASSANDRA-9066 and CASSANDRA-9060, it appears we do some
> unnecessary byte swapping during the serialization of bloom filters, which
> makes the logic slower and harder to follow. We should either perform them
> more efficiently (using Long.reverseBytes) or, preferably, eliminate the
> conversion altogether since it does not appear to serve any purpose.
--
This message was sent by Atlassian JIRA
(v7.6.3#76005)
---------------------------------------------------------------------
To unsubscribe, e-mail: [email protected]
For additional commands, e-mail: [email protected]