[
https://issues.apache.org/jira/browse/CASSANDRA-14756?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16627869#comment-16627869
]
Ariel Weisberg commented on CASSANDRA-14756:
--------------------------------------------
+1 modulo tests passing and the one thing I just pointed out where the
assertion now occurs after filtering and should be before.
> Transient Replication - range movement improvements
> ---------------------------------------------------
>
> Key: CASSANDRA-14756
> URL: https://issues.apache.org/jira/browse/CASSANDRA-14756
> Project: Cassandra
> Issue Type: Improvement
> Reporter: Alex Petrov
> Assignee: Alex Petrov
> Priority: Major
> Labels: pull-request-available
> Time Spent: 10m
> Remaining Estimate: 0h
>
> * Simplify iteration in calculateRangesToFetchWithPreferredEndpoints
> * Minor changes to calculateRangesToFetchWithPreferredEndpoints to improve
> readability:
> * Simplify RangeRelocator code
> * Fix range relocation
> * Simplify calculateStreamAndFetchRanges
> * Unify request/transfer ranges interface (Added benefit of this change is
> that we have a check for non-intersecting ranges)
> * Simplify iteration in calculateRangesToFetchWithPreferredEndpoints
> * Improve error messages
--
This message was sent by Atlassian JIRA
(v7.6.3#76005)
---------------------------------------------------------------------
To unsubscribe, e-mail: [email protected]
For additional commands, e-mail: [email protected]