[
https://issues.apache.org/jira/browse/CASSANDRA-14761?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16673859#comment-16673859
]
Joseph Lynch commented on CASSANDRA-14761:
------------------------------------------
Just a quick pass, it looks like most of it was just search and replace of
speculative with additional...
* As a user I find this new naming pretty confusing, and I'm curious what
other users think. I think there is significant mind-share in the community and
indeed other distributed systems (e.g. hadoop) around the concept of
{{speculative}} execution of idempotent operations. If anything I think it
makes sense to do {{speculative_read_policy}} and
{{speculative_transient_write_policy}}. Even if we keep the
{{additional_read_policy}} and {{additional_write_policy}} naming I worry a
user could easily confuse these somewhat different features (I know that I was
confused at first).
* I think most of the failing dtests are coming from [the unconditional check
|https://github.com/apache/cassandra/compare/trunk...aweisberg:14761-trunk?expand=1#diff-bd6d5666428f5bf5ce73a1c6a32bfb6bR137]
that the objects are equal even if one isn't set. Perhaps only check they are
equal if they are both set?. Also the string format swaps speculativeRetry with
additionReadPolicy (which should probably be additional).
* (docs) Did you mean to [remove the speculative read
option|https://github.com/apache/cassandra/compare/trunk...aweisberg:14761-trunk?expand=1#diff-911d9ab4d38f8f4be9752d968d414a26R463]?
I think you would want both {{additional_write}} and {{additional_read}} in
the table?
* (docs) If I understand speculative transient replica upgrade right, this
[text|https://github.com/apache/cassandra/compare/trunk...aweisberg:14761-trunk?expand=1#diff-911d9ab4d38f8f4be9752d968d414a26R496]
no longer applies to just read coordinators.
* (metrics) {{AdditionalReadsFailed}} [appears to be
inconsistent|https://github.com/apache/cassandra/compare/trunk...aweisberg:14761-trunk?expand=1#diff-40a2ae61c758454cc6166903250edbdfR844]
with the other new in 4.0 metrics ({{SpeculativeInsufficientRetries}} and
{{SpeculativeSampleLatencyNanos}}). Personally I like the Speculative name
across the board (esp since if we change {{SpeculativeRetries}} it's not
backwards compatible).
> Rename speculative_retry to match additional_write_policy
> ---------------------------------------------------------
>
> Key: CASSANDRA-14761
> URL: https://issues.apache.org/jira/browse/CASSANDRA-14761
> Project: Cassandra
> Issue Type: Improvement
> Components: Core
> Reporter: Ariel Weisberg
> Assignee: Ariel Weisberg
> Priority: Major
> Fix For: 4.0
>
>
> It's not really speculative. This commit is where it was last named and shows
> what to update
> https://github.com/aweisberg/cassandra/commit/e1df8e977d942a1b0da7c2a7554149c781d0e6c3
--
This message was sent by Atlassian JIRA
(v7.6.3#76005)
---------------------------------------------------------------------
To unsubscribe, e-mail: [email protected]
For additional commands, e-mail: [email protected]