[ 
https://issues.apache.org/jira/browse/CASSANDRA-15346?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16949203#comment-16949203
 ] 

N Sujit Kumar commented on CASSANDRA-15346:
-------------------------------------------

without 'allow filtering' there is another alternate is secondary index. which 
is suggestible? can you please confirm? as we have already 1TB data nearly 
loaded in that table, if created index will it occupy additional space? 

> ReadTimeout: Error from server: code=1200 [Coordinator node timed out waiting 
> for replica nodes' responses]
> -----------------------------------------------------------------------------------------------------------
>
>                 Key: CASSANDRA-15346
>                 URL: https://issues.apache.org/jira/browse/CASSANDRA-15346
>             Project: Cassandra
>          Issue Type: Bug
>          Components: CQL/Semantics, CQL/Syntax
>            Reporter: N Sujit Kumar
>            Priority: Normal
>
> Hi,
> We have created table with below schema:
> create table test_table(col_1 text, col_2 text, col_3 text, col_4 text, col_5 
> text, col_6 text, col_7 text, PRIMARY KEY (col_1, col_2, col_3, col_4, 
> col_5));
> {color:#de350b}this table contains nearly billions of records.(huge record 
> count) {color} 
> and tried to query like below,
> select * from test_table where col_1='value' and col_2='value'; --> 
> {color:#00875a}getting results{color}
> but when we tried like below,
> select * from test_table where col_1='value' and col_3='value' allow 
> filtering; -->{color:#de350b} not getting{color} results
> select * from test_table where col_1='value' and col_4='value' allow 
> filtering; --> {color:#de350b}not getting{color} results
> we are getting below error:
> "ReadTimeout: Error from server: code=1200 [Coordinator node timed out 
> waiting for replica nodes' responses] message="Operation timed out - received 
> only 0 responses." info=\{'received_responses': 0, 'required_responses': 1, 
> 'consistency': 'ONE'}"
> After i got above error, i have extended the timeout parameters from 5 
> seconds to 60 minutes in cassandra.yaml configuration file. 
> {color:#de350b}then result came, but taking very long time with 50 minutes of 
> execution time.{color}
> Can anyone suggest me to solve the "ReadTimeout:" issue without extending the 
> configuration?
> Thanks,
> Sujit
>  



--
This message was sent by Atlassian Jira
(v8.3.4#803005)

---------------------------------------------------------------------
To unsubscribe, e-mail: commits-unsubscr...@cassandra.apache.org
For additional commands, e-mail: commits-h...@cassandra.apache.org

Reply via email to