[ 
https://issues.apache.org/jira/browse/CASSANDRA-15570?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=17037356#comment-17037356
 ] 

Jon Haddad commented on CASSANDRA-15570:
----------------------------------------

Definitely an ergonomic improvement, I like it.

> Change name of table metrics virtual table percentile columns
> -------------------------------------------------------------
>
>                 Key: CASSANDRA-15570
>                 URL: https://issues.apache.org/jira/browse/CASSANDRA-15570
>             Project: Cassandra
>          Issue Type: Improvement
>            Reporter: Chris Lohfink
>            Priority: Normal
>
> The column names {{50th}} and {{90th}} are difficult to query as a selector 
> or in aggregation functions since our parser expects a letter for initial 
> char. It currently requires quoting like:
> {code:sql}
> SELECT table_name, "50th_ms", "99th_ms" FROM system_views.local_read_latency
> {code}
> Which is kinda difficult and non obvious, the error we give when not quoted 
> also isnt that helpful. Since it is percentile a simple thing is to just ad a 
> p infront:
> {code:sql}
> SELECT table_name, p50th_ms, p99th_ms FROM system_views.local_read_latency
> {code}



--
This message was sent by Atlassian Jira
(v8.3.4#803005)

---------------------------------------------------------------------
To unsubscribe, e-mail: commits-unsubscr...@cassandra.apache.org
For additional commands, e-mail: commits-h...@cassandra.apache.org

Reply via email to