[ 
https://issues.apache.org/jira/browse/CASSANDRA-3762?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13267885#comment-13267885
 ] 

Pavel Yaskevich commented on CASSANDRA-3762:
--------------------------------------------

bq. If we get the real value, this will cause a cache Hit and another cache hit 
for saving the value. We just need a estimate and we dont need to be accurate 
IMHO. Added documentation for the same.

It means that the method don't return what what it should and should be renamed 
to *estimate*SerializedSize but as we would to the same for all of the rows in 
the cache I don't see how it would harm LRU if we do the real calculation.

bq. AutoSavingCache.loadSaved(...) method should return if exception occurred 
while loading old style cache. - It does :)

It does not :) Just uses "logger.warn(String.format("error reading saved cache 
%s", path.getAbsolutePath()), e);" and would go on with processing, it also 
should have the same error message as the next "new" case.

bq. we should probably make CacheSerialize.serialize method to return size of 
the serialized data, would be useful upon cache writes instead of explicitly 
calling serializedSize

What about this one?


                
> AutoSaving KeyCache and System load time improvements.
> ------------------------------------------------------
>
>                 Key: CASSANDRA-3762
>                 URL: https://issues.apache.org/jira/browse/CASSANDRA-3762
>             Project: Cassandra
>          Issue Type: Improvement
>          Components: Core
>    Affects Versions: 1.2
>            Reporter: Vijay
>            Assignee: Vijay
>            Priority: Minor
>             Fix For: 1.2
>
>         Attachments: 0001-CASSANDRA-3762-v2.patch, 
> 0001-CASSANDRA-3762-v3.patch, 0001-CASSANDRA-3762-v4.patch, 
> 0001-SavedKeyCache-load-time-improvements.patch
>
>
> CASSANDRA-2392 saves the index summary to the disk... but when we have saved 
> cache we will still scan through the index to get the data out.
> We might be able to separate this from SSTR.load and let it load the index 
> summary, once all the SST's are loaded we might be able to check the 
> bloomfilter and do a random IO on fewer Index's to populate the KeyCache.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: 
https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Reply via email to