[ 
https://issues.apache.org/jira/browse/CASSANDRA-6572?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14006452#comment-14006452
 ] 

Lyuben Todorov edited comment on CASSANDRA-6572 at 5/22/14 8:52 PM:
--------------------------------------------------------------------

Commit 
[3bd3ddc|https://github.com/lyubent/cassandra/commit/3bd3ddc5f2b2068895f57a753b2ca2c7431c07b8]:
# {{runFlush()}} is used in SS to force a flush should the query recording be 
disabled \/ cassandra gets shut down, but I renamed it to {{forceFlush}} for 
clarity. 
# added an interface that gives us access to a statement's keyspace from 
CFMetaData. {{isSystemOrTraceKS}} now uses the keyspace from the CFMetaData\. 
Batch statements are special-cased as they contain more than just a single 
keyspace (might possibly change this further along once we get to replaying of 
batches). (separate commit 
[here|https://github.com/lyubent/cassandra/commit/1b10a60de35c2f5b69f8100edc551c93d4bbe027])
 
# Updated QR to recycle QQs which get stored onto the CLQ. 
# Added a small optimisation, BBs used for creating the data array in 
{{QR#allocate(String)}} are now recycled where the largest buffer created is 
stored, when a bigger one is required it gets allocated and replaces the older 
one.
# Added forceFlush to the shutdown process.

P.S. The more this develops, the more it seems like QR should be a singleton, I 
think it wont be a big change at all to modify it to be one, not that the 
current design is a problem, just an idea to consider. 


was (Author: lyubent):
Commit 
[3bd3ddc|https://github.com/lyubent/cassandra/commit/3bd3ddc5f2b2068895f57a753b2ca2c7431c07b8]:
# {{runFlush()}} is used in SS to force a flush should the query recording be 
disabled / cassandra gets shut down, but I renamed it to {{forceFlush}} for 
clarity. 
# added an interface that gives us access to a statement's keyspace from 
CFMetaData. {{isSystemOrTraceKS}} now uses the keyspace from the CFMetaData, 
{{BatchStatement}}s are special-cased as they contain more than just a single 
keyspace (might possibly change this further along once we get to replaying of 
batches). 
# Updated QR to recycle QQs which get stored onto the CLQ. 
# Added a small optimisation, BBs used for creating the data array in 
{{QR#allocate(String)}} are now recycled where the largest buffer created is 
stored, when a bigger one is required it gets allocated and replaces the older 
one.
# Added forceFlush to the shutdown process.

P.S. The more this develops, the more it seems like QR should be a singleton, I 
think it wont be a big change at all to modify it to be one, not that the 
current design is a problem, just an idea to consider. 

> Workload recording / playback
> -----------------------------
>
>                 Key: CASSANDRA-6572
>                 URL: https://issues.apache.org/jira/browse/CASSANDRA-6572
>             Project: Cassandra
>          Issue Type: New Feature
>          Components: Core, Tools
>            Reporter: Jonathan Ellis
>            Assignee: Lyuben Todorov
>             Fix For: 2.1.1
>
>         Attachments: 6572-trunk.diff
>
>
> "Write sample mode" gets us part way to testing new versions against a real 
> world workload, but we need an easy way to test the query side as well.



--
This message was sent by Atlassian JIRA
(v6.2#6252)

Reply via email to