This is an automated email from the ASF dual-hosted git repository. leborchuk pushed a commit to branch REL_2_STABLE in repository https://gitbox.apache.org/repos/asf/cloudberry.git
commit 0b9a70f2b950324b868386151f588b46270bc88c Author: Magnus Hagander <[email protected]> AuthorDate: Thu Jan 11 14:27:10 2024 +0100 Fix omission in partitioning limitation documentation UNIQUE and PRIMARY KEY constraints can be created on ONLY the partitioned table. We already had an example demonstrating that, but forgot to mention it in the documentation of the limits of partitioning. Author: Laurenz Albe Reviewed-By: shihao zhong, Shubham Khanna, Ashutosh Bapat Backpatch-through: 12 Discussion: https://postgr.es/m/[email protected] (cherry picked from commit 5b0287adcab35c1e55d007ba3037c49bd7536ee8) --- doc/src/sgml/ddl.sgml | 4 +++- 1 file changed, 3 insertions(+), 1 deletion(-) diff --git a/doc/src/sgml/ddl.sgml b/doc/src/sgml/ddl.sgml index f99052fa5c2..536f97a6be3 100644 --- a/doc/src/sgml/ddl.sgml +++ b/doc/src/sgml/ddl.sgml @@ -4146,7 +4146,9 @@ ALTER INDEX measurement_city_id_logdate_key Using <literal>ONLY</literal> to add or drop a constraint on only the partitioned table is supported as long as there are no partitions. Once partitions exist, using <literal>ONLY</literal> - will result in an error. Instead, constraints on the partitions + will result in an error for any constraints other than + <literal>UNIQUE</literal> and <literal>PRIMARY KEY</literal>. + Instead, constraints on the partitions themselves can be added and (if they are not present in the parent table) dropped. </para> --------------------------------------------------------------------- To unsubscribe, e-mail: [email protected] For additional commands, e-mail: [email protected]
