Updated Branches:
  refs/heads/4.3 bd335d01c -> c1af92fcb

CLOUDSTACK-6007. Restore VM command fails with NPE.
If a VM instance is deployed with startVm=false, then calling restoreVm on the 
instance fails with NPE because CS tries to expunge a volume that has not been 
created in primary store.
(cherry picked from commit 92abb9439e7a4f18d79e2a48e72a0ee94d84f477)

Signed-off-by: Animesh Chaturvedi <[email protected]>


Project: http://git-wip-us.apache.org/repos/asf/cloudstack/repo
Commit: http://git-wip-us.apache.org/repos/asf/cloudstack/commit/31d1da56
Tree: http://git-wip-us.apache.org/repos/asf/cloudstack/tree/31d1da56
Diff: http://git-wip-us.apache.org/repos/asf/cloudstack/diff/31d1da56

Branch: refs/heads/4.3
Commit: 31d1da56814a17ee816207619fb8281b9647a58e
Parents: bd335d0
Author: Likitha Shetty <[email protected]>
Authored: Mon Feb 3 11:34:54 2014 +0530
Committer: Animesh Chaturvedi <[email protected]>
Committed: Fri Feb 7 13:13:49 2014 -0800

----------------------------------------------------------------------
 server/src/com/cloud/vm/UserVmManagerImpl.java | 18 +++++++++++-------
 1 file changed, 11 insertions(+), 7 deletions(-)
----------------------------------------------------------------------


http://git-wip-us.apache.org/repos/asf/cloudstack/blob/31d1da56/server/src/com/cloud/vm/UserVmManagerImpl.java
----------------------------------------------------------------------
diff --git a/server/src/com/cloud/vm/UserVmManagerImpl.java 
b/server/src/com/cloud/vm/UserVmManagerImpl.java
index d9923d2..81be19f 100755
--- a/server/src/com/cloud/vm/UserVmManagerImpl.java
+++ b/server/src/com/cloud/vm/UserVmManagerImpl.java
@@ -71,6 +71,7 @@ import 
org.apache.cloudstack.engine.service.api.OrchestrationService;
 import org.apache.cloudstack.engine.subsystem.api.storage.TemplateDataFactory;
 import org.apache.cloudstack.engine.subsystem.api.storage.TemplateInfo;
 import org.apache.cloudstack.engine.subsystem.api.storage.VolumeDataFactory;
+import org.apache.cloudstack.engine.subsystem.api.storage.VolumeInfo;
 import org.apache.cloudstack.engine.subsystem.api.storage.VolumeService;
 import 
org.apache.cloudstack.engine.subsystem.api.storage.VolumeService.VolumeApiResult;
 import org.apache.cloudstack.framework.async.AsyncCallFuture;
@@ -5113,14 +5114,17 @@ public class UserVmManagerImpl extends ManagerBase 
implements UserVmManager, Vir
         _volsDao.detachVolume(root.getId());
         volumeMgr.destroyVolume(root);
 
-        // For VMware hypervisor since the old root volume is replaced by the 
new root volume in storage, force expunge old root volume
+        // For VMware hypervisor since the old root volume is replaced by the 
new root volume, force expunge old root volume if it has been created in storage
         if (vm.getHypervisorType() == HypervisorType.VMware) {
-            s_logger.info("Expunging volume " + root.getId() + " from primary 
data store");
-            AsyncCallFuture<VolumeApiResult> future = 
_volService.expungeVolumeAsync(volFactory.getVolume(root.getId()));
-            try {
-                future.get();
-            } catch (Exception e) {
-                s_logger.debug("Failed to expunge volume:" + root.getId(), e);
+            VolumeInfo volumeInStorage = volFactory.getVolume(root.getId());
+            if (volumeInStorage != null) {
+                s_logger.info("Expunging volume " + root.getId() + " from 
primary data store");
+                AsyncCallFuture<VolumeApiResult> future = 
_volService.expungeVolumeAsync(volFactory.getVolume(root.getId()));
+                try {
+                    future.get();
+                } catch (Exception e) {
+                    s_logger.debug("Failed to expunge volume:" + root.getId(), 
e);
+                }
             }
         }
 

Reply via email to