houthuis opened a new pull request #2442: CLOUDSTACK-10147 Disabled Xenserver 
Cluster can still deploy VM's
URL: https://github.com/apache/cloudstack/pull/2442
 
 
   ENVIRONMENT 
   ===================== 
   XenServer Version : 6.2 , 7
   
   ISSUE 
   ================== 
   Disabled Xenserver Cluster can still deploy VM's , hosts in the cluster are 
still active
   
   Repro. steps followed 
   ================== 
   Disabled Cluster from UI. 
   Deploy a new VM
   
   Expected Behavior 
   ===============
   After disabling the cluster , the hosts should be disabled. and no VM's can 
be deployed
   
   Note:
   it's the same results for XenServer or simulator, can't deploy on disabled 
hosts, but can deploy on disabled cluster
   
   Solution:
   
   Added a check to skip disabled clusters when selecting a host to deploy on.
   Deploying on a disabled cluster will now result in a 
InsufficientServerCapacityException, if no enabled clusters are found.
   
   i didn't want to propagate disabling a cluster down to the hosts, because 
then you would have to enable all the hosts again when you enable the cluster, 
and we won't know which hosts should be left in a disabled state

----------------------------------------------------------------
This is an automated message from the Apache Git Service.
To respond to the message, please log on GitHub and use the
URL above to go to the specific comment.
 
For queries about this service, please contact Infrastructure at:
us...@infra.apache.org


With regards,
Apache Git Services

Reply via email to