Repository: cxf-fediz
Updated Branches:
  refs/heads/master 3610309d1 -> dd65d5a30


Fix dependencies to beanutils and ognl.   This closes #10.

Idp has a dependency to :
 * both commons-beanutils-core:1.8.3 and commons-beanutils:1.9.2.
 * opensymphony:ognl and ognl:ognl

Excluded dependency to the oldest version of libraries.


Project: http://git-wip-us.apache.org/repos/asf/cxf-fediz/repo
Commit: http://git-wip-us.apache.org/repos/asf/cxf-fediz/commit/dd65d5a3
Tree: http://git-wip-us.apache.org/repos/asf/cxf-fediz/tree/dd65d5a3
Diff: http://git-wip-us.apache.org/repos/asf/cxf-fediz/diff/dd65d5a3

Branch: refs/heads/master
Commit: dd65d5a302c87f75bd842cf5ee11cfce206e615f
Parents: 3610309
Author: Adrian Gonzalez <adr_gonza...@yahoo.fr>
Authored: Sun Sep 18 22:24:21 2016 +0200
Committer: Colm O hEigeartaigh <cohei...@apache.org>
Committed: Mon Sep 19 10:10:42 2016 +0100

----------------------------------------------------------------------
 services/idp/pom.xml | 14 ++++++++++++++
 1 file changed, 14 insertions(+)
----------------------------------------------------------------------


http://git-wip-us.apache.org/repos/asf/cxf-fediz/blob/dd65d5a3/services/idp/pom.xml
----------------------------------------------------------------------
diff --git a/services/idp/pom.xml b/services/idp/pom.xml
index b7e918f..e3ce225 100644
--- a/services/idp/pom.xml
+++ b/services/idp/pom.xml
@@ -100,6 +100,12 @@
             <groupId>org.springframework.webflow</groupId>
             <artifactId>spring-webflow</artifactId>
             <version>2.3.4.RELEASE</version>
+            <exclusions>
+                <exclusion>
+                    <groupId>opensymphony</groupId>
+                    <artifactId>ognl</artifactId>
+                </exclusion>
+            </exclusions>
         </dependency>
         <dependency>
             <groupId>org.springframework.security</groupId>
@@ -256,6 +262,14 @@
                     <groupId>com.sun.xml.bind</groupId>
                     <artifactId>jaxb-impl</artifactId>
                 </exclusion>
+                <!-- 
+                dependency to newer version (commons-beanutils)
+                imported from commons-validator
+                -->
+                <exclusion>
+                    <groupId>commons-beanutils</groupId>
+                    <artifactId>commons-beanutils-core</artifactId>
+                </exclusion>
             </exclusions>
         </dependency>
         <dependency>

Reply via email to