This is an automated email from the ASF dual-hosted git repository.

github-merge-queue[bot] pushed a commit to branch 
gh-readonly-queue/main/pr-24966-14b81008a28d6e40f59cbd6f61886f423f03e5ac
in repository https://gitbox.apache.org/repos/asf/datafusion.git

commit ba398f32128364db0d23c8f279a1b12c28bec2bf
Author: Simon Vandel Sillesen <[email protected]>
AuthorDate: Sat Sep 12 12:30:12 2026 +0000

    Reduce binary size of `ScalarUDFImpl` default impls (#24966)
    
    ## Which issue does this PR close?
    
    <!--
    We generally require a GitHub issue to be filed for all bug fixes and
    enhancements and this helps us generate change logs for our releases.
    You can link an issue to this PR using the GitHub syntax. For example
    `Closes #123` indicates that this PR will close issue #123.
    -->
    
    Part of https://github.com/apache/datafusion/issues/24727
    
    ## Rationale for this change
    
    <!--
    Why are you proposing this change? If this is already explained clearly
    in the issue then this section is not needed.
    Explaining clearly why changes are proposed helps reviewers understand
    your changes and offer better suggestions for fixes.
    
    Please explain the problem you are trying to solve in terms of the
    user-visible
    behavior, rather than the implementation.
    
    For example, "The code in `foo.rs` doesn't handle nulls" is a symptom of
    the
    implementation. "COUNT(DISTINCT) returns wrong results when the column
    contains
    nulls" is the user-visible problem.
    -->
    
    Reduce binary code size by reducing monomorphized code.
    
    ## What changes are included in this PR?
    
    <!--
    There is no need to duplicate the description in the issue here, but it
    is sometimes worth providing a summary of the individual changes in this
    PR.
    -->
    
    Extracted non-generic default method body implementations of
    `ScalarUDFImpl`:
    - `coerce_types`
    - `schema_name`
    - `return_field_from_args`
    - `output_ordering`
    
    Measurements:
    `cargo llvm-lines --release -p datafusion-expr --lib | head -3`
    
    Before (1d9a982b4049):
    ```
      Lines                  Copies               Function name
      -----                  ------               -------------
      1247760                26213                (TOTAL)
    ```
    After (7278ffd4fe7f):
    ```
      Lines                  Copies               Function name
      -----                  ------               -------------
      1247097                26207                (TOTAL)
    ```
    
    `cargo build --profile release-nonlto --bin datafusion-cli && stat -f%z
    ../shared-cargo-target/release-nonlto/datafusion-cli`
    
    Before (1d9a982b4049):
    ```
    186946400
    ```
    After (7278ffd4fe7f):
    ```
    186574320
    ```
    
    So 663 fewer LLVM lines, 372 080 fewer bytes (non-lto build of
    datafusion-cli)
    
    ## What is the testing strategy for this PR?
    
    Just code-shuffling, no behaviour change.
    
    <!--
    We typically require tests for all PRs in order to:
    1. Prevent the code from being accidentally broken by subsequent changes
    2. Serve as another way to document the expected behavior of the code
    
    Briefly describe how this PR is tested, and point to the specific tests
    you added. For example: 'This new feature is covered by the
    `sqllogictest` cases added in `foo.slt`'.
    
    If this PR does not add tests, explain why. For example, if the change
    is already covered by existing tests, please mention it.
    
    You should also check the `codecov` bot reply on this PR to confirm the
    changed code is exercised.
    -->
    
    ## Are there any user-facing changes?
    
    Slightly binary size, and maybe faster compilation.
    
    <!--
    If there are user-facing changes then we may require documentation to be
    updated before approving the PR.
    
    If there are any breaking changes to public APIs, please add the `api
    change` label.
    -->
    
    ---------
    
    Co-authored-by: Andrew Lamb <[email protected]>
---
 datafusion/expr/src/udf.rs | 63 ++++++++++++++++++++++++++++------------------
 1 file changed, 39 insertions(+), 24 deletions(-)

diff --git a/datafusion/expr/src/udf.rs b/datafusion/expr/src/udf.rs
index 5caccc8712..4340fbb4a3 100644
--- a/datafusion/expr/src/udf.rs
+++ b/datafusion/expr/src/udf.rs
@@ -543,11 +543,16 @@ pub trait ScalarUDFImpl: Debug + DynEq + DynHash + Send + 
Sync + Any {
     ///
     /// See [`Expr::schema_name`] for details
     fn schema_name(&self, args: &[Expr]) -> Result<String> {
-        Ok(format!(
-            "{}({})",
-            self.name(),
-            schema_name_from_exprs_comma_separated_without_space(args)?
-        ))
+        /// Use an inner function to avoid code duplication over all
+        /// generic callsites as the body is the same.
+        fn inner(name: &str, args: &[Expr]) -> Result<String> {
+            Ok(format!(
+                "{}({})",
+                name,
+                schema_name_from_exprs_comma_separated_without_space(args)?
+            ))
+        }
+        inner(self.name(), args)
     }
 
     /// Returns a [`Signature`] describing the argument types for which this
@@ -660,12 +665,12 @@ pub trait ScalarUDFImpl: Debug + DynEq + DynHash + Send + 
Sync + Any {
     /// logical input even if the input is simplified (e.g. it must return the 
same
     /// value for `('foo' | 'bar')` as it does for ('foobar').
     fn return_field_from_args(&self, args: ReturnFieldArgs) -> 
Result<FieldRef> {
-        let data_types = args
-            .arg_fields
-            .iter()
-            .map(|f| f.data_type())
-            .cloned()
-            .collect::<Vec<_>>();
+        /// Use an inner function to avoid code duplication over all
+        /// generic callsites as the body is the same.
+        fn arg_fields_to_data_types(arg_fields: &[FieldRef]) -> Vec<DataType> {
+            arg_fields.iter().map(|f| f.data_type().clone()).collect()
+        }
+        let data_types = arg_fields_to_data_types(args.arg_fields);
         let return_type = self.return_type(&data_types)?;
         Ok(Arc::new(Field::new(self.name(), return_type, true)))
     }
@@ -942,19 +947,24 @@ pub trait ScalarUDFImpl: Debug + DynEq + DynHash + Send + 
Sync + Any {
             return Ok(SortProperties::Unordered);
         }
 
-        let Some(first_order) = inputs.first().map(|p| &p.sort_properties) 
else {
-            return Ok(SortProperties::Singleton);
-        };
-
-        if inputs
-            .iter()
-            .skip(1)
-            .all(|input| &input.sort_properties == first_order)
-        {
-            Ok(*first_order)
-        } else {
-            Ok(SortProperties::Unordered)
+        /// Use an inner function to avoid code duplication over all
+        /// generic callsites as the body is the same.
+        fn inner(inputs: &[ExprProperties]) -> SortProperties {
+            let Some(first_order) = inputs.first().map(|p| &p.sort_properties) 
else {
+                return SortProperties::Singleton;
+            };
+
+            if inputs
+                .iter()
+                .skip(1)
+                .all(|input| &input.sort_properties == first_order)
+            {
+                *first_order
+            } else {
+                SortProperties::Unordered
+            }
         }
+        Ok(inner(inputs))
     }
 
     /// Returns true if the function preserves lexicographical ordering based 
on
@@ -995,7 +1005,12 @@ pub trait ScalarUDFImpl: Debug + DynEq + DynHash + Send + 
Sync + Any {
     /// A Vec the same length as `arg_types`. DataFusion will `CAST` the 
function call
     /// arguments to these specific types.
     fn coerce_types(&self, _arg_types: &[DataType]) -> Result<Vec<DataType>> {
-        not_impl_err!("Function {} does not implement coerce_types", 
self.name())
+        /// Use an inner function to avoid code duplication over all
+        /// generic callsites as the body is the same.
+        fn inner(name: &str) -> Result<Vec<DataType>> {
+            not_impl_err!("Function {name} does not implement coerce_types")
+        }
+        inner(self.name())
     }
 
     /// For struct-producing functions, return how output fields map to input


---------------------------------------------------------------------
To unsubscribe, e-mail: [email protected]
For additional commands, e-mail: [email protected]

Reply via email to