This is an automated email from the ASF dual-hosted git repository.
leerho pushed a change to branch update_7.0.X
in repository https://gitbox.apache.org/repos/asf/datasketches-memory.git
from 1bb0f275 Update .gitignore consistent with main
add b08228b1 Creating java17 module, step 1.
add 98a74d28 Interim
add 433552ef Interim2
add 094c9bb8 Interim - does not compile. Problems compiling 17.
add 4fab7e4c Add tests from "java17old"
add 1a8c9a7e Change method of accessing Resource file GettysburgAddress.txt
add 74bccd3c Remove SuppressWarnings("javadoc")
add 66600b46 Temporary commit
add a6fa005d update poms.
add d32c11f3 transition to single memory project for just java 17
add 50d4f9b8 Add getArray(), comment out a bunch of SuppressWarnings:
resource & javadoc.
add 88d94c84 Change tests to accommodate:
add 3c826331 Creating compatibility between a ds-java 7.X.X and a Memory
3.X.X
add 2b5b3731 Add test for issue 178
add abda66e1 Add "--add-modules=jdk.incubator.foreign" in properties
argLine and compiler plugin.
add 7791ddcc fix typos, etc.
add bedd46e3 more formatting cleanup
add 7c09a24f Change BaseState to Resource
add 923336c8 Rename BaseStateImpl to ResourceImpl
add 249b71ef rename BaseStateTest to ResourceTest
add cc7084e6 Update Memory:
add 690e3f57 Changes in preparation for a Memory 4.0.0 for Java 17 only
add b4eb1980 More improvements
add 3f528f4e minor correction to pom
add 24f558c9 Changes required to integrate FFM/Panama into ds-Memory.
add a1b72e22 Align with the java8 3.0.0 version
add f2f32e69 More changes to align 3.0.0 with 4.0.0
add bb575833 Update tests -- mostly comments.
add afa0b744 make Util.getResourcePath(..) private
add cdd473cd Fix illegal Javadoc tag.
add d09aa969 Mostly minor changes to bring the Java 17 API closer to the
Java 8-11 API.
add 8ca31260 Merge pull request #217 from apache/change_toHex_to_toString
add abd2d58a Update main
add 66997503 Merge pull request #219 from
apache/Release_process_update_main
add 568a21a4 Changes in mostly documentation to alert users
add c08c2c83 update main with the java17 edits from 4.0.X
add 2a08f94d make NOTICE, pom and README in main the same as 4.0.X
add dda60cec Merge pull request #226 from apache/update_main_from_4.0.X
add 0cfcdcf2 Merge branch 'main' of
[email protected]:apache/datasketches-memory.git into main
add dc6753ce Forgot this one. :)
add 73411e10 Merge pull request #227 from
apache/more_changes_for_main_for_next_time
add fff9329e Update javadoc workflow
add 0e1be847 Try fix javadoc workflow
add 7d9167a1 fix syntax
add 5a62116f Remove lines 16-21
add c2019c3a fixed path, build main branch
add 7e79fd3c Merge pull request #230 from
apache/update_javadoc_workflow_on_main
add 9616facc Merge branch 'main' into update_javadoc_workflow_on_main
add 81c0ce68 Merge branch 'update_javadoc_workflow_on_main' of
[email protected]:apache/datasketches-memory.git into
update_javadoc_workflow_on_main
add b6218cb2 Merge pull request #232 from
apache/update_javadoc_workflow_on_main
add 8c75bacb Change setup-java to v4
add 5d33434a Merge pull request #233 from
apache/update_javadoc_workflow_on_main
add dd5d421d conclude merge
add e0ee9c5f minor changes in wording.
add 903b1bcb update manual coverage yml
add 01eb0f22 change set read only
add e6783c25 change UtilTest set to readonly.
add 55f659c2 print FILE SET READ ONLY
add a20f42d1 Change UtilTest.resourceBytesCorrect()
add eab4b1e7 update UtilTest.resourceBytesCorrect again.
add 695ed45d try fix AllocateDirectWritableMapMemoryTest.testForce()
add 184af5b9 Clean up unnecessary SuppressWarnings("resource")
add fe1ee5d7 update GH Actions
add a055c17a remove unused toolchains.xml
add dfa87631 remove name conflict
add aa1ed983 Merge pull request #235 from leerho/minor_changes_in_wording
add c9c0cecc check for slash-Rs
add a1e31dea test again
add e32cd596 try again
add 35f4897f again and again
add 46b1dad1 again, fix rat -> bin
add 94194b45 yes again
add 75e790e5 again2
add 2d79a568 update leerho remote
add 06fe7ac0 update remote 2
add ba741305 Abandon depending on file lengths.
add c8e4f772 update GH Actions
add fb76f8f3 revert pom & delete GettysburgAddress.bin
add 75da3c78 fix test
add 422a9242 Merge pull request #236 from leerho/minor_changes_in_wording
add cb396aa2 Remove two experimental GH Actions
add 79fc105d Merge pull request #234 from apache/minor_changes_in_wording
add 809f9fa5 Update main to 4.2.0-SNAPSHOT Release Process
add cf662bfc Merge pull request #239 from
apache/Update_main_version_to_4.2.0-SNAPSHOT
add b382eb0b Migrate to Java 21 FFM API
add 56bc3f33 Update GHA workflows to Java 21
add 44d31d75 Minor cleanup based on PR feedback
add 6dd9d4f3 Improve temp file creation in test suite
add 98a0ac83 Improve temp file creation in test suite
add da1dd627 Merge pull request #241 from frankgrimes97/feature/java-21-ffm
add b874e6b5 Update frank_grimes_java-21-ffm
add 5147a45e Update minor checkstyle fixes, re-arrange a few method
signatures.
add f7ab4f2f Refactored method params so Arena is last param.
add fa956698 change not supported to not recommended.
add 9db3bfb0 create "enable.preview" property in pom
add 1de7cdfd Fix some Javadoc errors.
add ff0fbe3e Updating the frank grimes java21 contribution.
add 11c93ee0 update readme & GH actions
add df3e05c9 remove references to Java 17
add 34c661c2 Updating java 17 code to use java 21 API.
add 0a15de07 disable a println statement
add 5d9cd189 Fixed ONLY indentation problems.
add bcc9d91b update frank_grimes_java-21-ffm
add 3350ab98 Merge pull request #242 from apache/frank_grimes_java-21-ffm
add 4a71d87c Release Process: fixed some SpotBugs "dead stores" in test
code.
add f5a6e1c9 Merge pull request #243 from apache/minor_fixes_to_main
add 9f213719 align workflows with the same ones from Java 17, except
targeting java 21
add f4779ebf Merge branch 'update_workflows_on_main' into
frank_grimes_java-21-ffm
add e7bc1306 Update frank_grimes_java-21-ffm
add 276bd2a9 Merge pull request #246 from apache/frank_grimes_java-21-ffm
add 3a926fac Minor corrections to NOTICE, pom.xml, and README.md
add 5ecff5bd Merge pull request #247 from apache/minor_corrections_to_main
add fe30ef39 Fixes a spot bugs issue.
add faec9664 Merge pull request #248 from apache/fix_spotbugs_issue
add ef4c4804 New Release Branch 5.0.X for Java 21
add d13507b0 Changes in /main/ tree to accommodate the new FFM API in Java
21.
add caa048db Minor tweaks to MemoryRequestServer and to Resource.
add 083b5e45 Missed this one ...
add 47107b1d Update javadoc and add 2 suppressWarnings
add c354c48e Change pom version to 5.1.0-SNAPSHOT
add fe214527 Merge pull request #249 from apache/changes_in_main_tree
add e937f329 Fixed a few SpotBugs Warnings.
add f8c51e1c Fix workflows to triggger
add fca6c8c7 Fix requested from review.
add c45f58d2 Merge pull request #250 from apache/fix_some_spotbugs_warnings
add 89fd0097 Update main ver to 6.1.0-SNAPSHOT
add b014dca6 Merge pull request #251 from apache/main_to_6.1.0-SNAPSHOT
add adb0f2ef fixed operator precedence bug in setPosition() calls
add af83326c Merge pull request #253 from pawel-wiejacha/fix_set_position
add b7b7437d Fixed all the tests which lacked the ability to test this bug.
add b55af703 Merge pull request #254 from apache/fix_setPosition
add 4c73fb46 a two letter typo.
add f6a7c58b Merge pull request #256 from apache/typo_in_main
add cabf9ca9 More comprehensive tests.
add 7f40e8b1 Add missing license
add e0faea24 Better test coverage AND actual checking for the
@pawel-weijacha bug for all the primitives.
add 22c79088 Merge pull request #257 from apache/better_test_coverage
add 07229434 Redo var names
add 1b9e7027 Merge pull request #259 from apache/Redo_var_names
add 9d29ac90 Update how Memory Request Server works.
add b529f867 Revised isSameResource()
add 05b76b0e Investigate Hash bug
add 38df8a7b Only change required to fix the Hash Bug.
add 1902d177 Added additional MurmurHash3 tests, especially to catch the
Hash bug.
add e9f998a1 Merge pull request #260 from apache/hash_bug
add 8ef26d72 Merge branch 'main' into update_memReqSvr
add 9a3b29be Improve javadoc for 'isSameResource(...)'
add 6f8adeac improve error comment.
add 602eac23 Allow getMemorySegment as read-only.
add c0b19797 Improve javadocs
add 52ac28c9 Move MurmurHash3 out of Memory into ds-java.
add 2ffc5dbc Merge pull request #262 from apache/update_memReqSvr
add 36b980aa Small change to POM.
add 4c030e04 add branch protection
add 029c147d oops, main not master
add da09cb52 update .asf.yaml
add 59162fdb Merge pull request #264 from apache/update_main
add ffd61825 Fix notice
add a580985b Merge pull request #267 from apache/fix_notice
add 57df366c Minimal changes required to make code compile with JDK 22, 23
and 24.
add 0c5c9e89 change pom for jdk 22
add fc35d386 Missing Finals.
add 49cd87ce Removed xxHash and dependency on
net.openhft.hashing.LongHashFunction, which is obsolete and depends on
sun.misc.unsafe.
add 439dfb04 changes (so far) for Java 24
add 9001c815 align pom with ds-java pom
add c3815ff3 Update Jacoco-plugin to 0.8.13
add d0536d28 branch main25 now runs on Java25.
add e5a67447 Update GHA workflows & Checkstyle
add 0bc9c15b Very minor typos.
add 087d73d3 Update auto-jdk-matrix.yml workflow.
add 3938e42d Add license header
add 8e297b98 enable push & pull_request
add 7e1f9d13 Update auto-os-matrix.yml
add 64db79c3 Update workflow
add bccb1757 update workflow
add 743d40a1 Add clean back into the install step.
add 9a125630 Update clean install step with individual double quotes.
add b03fe339 Add comments
add 305b9860 merge jdk and os yml files
add ab8c4343 update Javadoc workflow
add 83859f3c Merge pull request #273 from apache/main25
add f72602d2 update pom.xml and add testng.xml
add 7071b969 update pom
add c0754763 Update @BeforeSuite
add 74c46ffd update pom.
add 3082c724 Removed DOCTYPE link as unnecessary
add 0b6bb807 Fix xml headers
add 93d9b9bc update *.xml
add 120d3758 Add new auto-jdk-os-matrix.yml that uses reusable workflows.
add 9a29f6e5 update auto-jdk-os-matrix.yml
add 9260eb97 Update caller
add cb655394 Add missing OS dimension
add 8859a2a4 Remove post-build-cleanup
add 05b267fb Update Maven Central badge
add b399cfdb Update pom, .mvn to align w/ ds-java
add 9ed75254 Update pom
add 84a546c9 Merge pull request #274 from apache/ToMain
add 78490663 update .asf.yaml to silence failed workflow messages.
add f7959c0a Name the WF placeholder.yml.
add 899fcf7a Edit comments
add 08f79902 Merge pull request #278 from apache/quick_update_to_main
add 4ab1ce08 Merge main but keep update_7.0.X exactly the same.
No new revisions were added by this update.
Summary of changes:
---------------------------------------------------------------------
To unsubscribe, e-mail: [email protected]
For additional commands, e-mail: [email protected]