Repository: groovy
Updated Branches:
  refs/heads/parrot 2f7e354a3 -> a9d95e04e


Merge branch 'master' of https://git-wip-us.apache.org/repos/asf/groovy into 
parrot


Project: http://git-wip-us.apache.org/repos/asf/groovy/repo
Commit: http://git-wip-us.apache.org/repos/asf/groovy/commit/a9d95e04
Tree: http://git-wip-us.apache.org/repos/asf/groovy/tree/a9d95e04
Diff: http://git-wip-us.apache.org/repos/asf/groovy/diff/a9d95e04

Branch: refs/heads/parrot
Commit: a9d95e04e1a83d41a56d740e1c73a55c494306c0
Parents: 2f7e354
Author: sunlan <sun...@apache.org>
Authored: Fri Jan 13 23:58:35 2017 +0800
Committer: sunlan <sun...@apache.org>
Committed: Fri Jan 13 23:58:35 2017 +0800

----------------------------------------------------------------------
 build.gradle | 21 +++++++++++++--------
 1 file changed, 13 insertions(+), 8 deletions(-)
----------------------------------------------------------------------


http://git-wip-us.apache.org/repos/asf/groovy/blob/a9d95e04/build.gradle
----------------------------------------------------------------------
diff --git a/build.gradle b/build.gradle
index 9343891..b3c6206 100644
--- a/build.gradle
+++ b/build.gradle
@@ -42,6 +42,8 @@ buildscript {
         //classpath 'nl.javadude.gradle.plugins:license-gradle-plugin:0.11.0'
         classpath "gradle.plugin.org.nosphere.apache:creadur-rat-gradle:0.1.3"
         classpath "gradle.plugin.com.github.jk1:gradle-license-report:0.3.2"
+
+        classpath files("lib/antlr4-gradle-plugin-0.1.2-SNAPSHOT.jar");
     }
 }
 
@@ -76,8 +78,8 @@ allprojects {
     apply plugin: 'java'
 
     buildDir = 'target'
-    sourceCompatibility = 1.7
-    targetCompatibility = 1.7
+    sourceCompatibility = 1.8
+    targetCompatibility = 1.8
 
     group = 'org.codehaus.groovy'
     version = groovyVersion
@@ -170,6 +172,7 @@ ext {
     xmlunitVersion = '1.6'
     xstreamVersion = '1.4.9'
     spockVersion = '1.0-groovy-2.4'
+    antlr4Version = '4.6.0.3'
     isReleaseVersion = !groovyVersion.toLowerCase().endsWith("snapshot")
 }
 
@@ -307,6 +310,8 @@ sourceSets {
     }
 }
 
+apply from: 'subprojects/groovy-parser-antlr4/build.gradle'
+
 // make sure examples can be compiled, even if we don't run them
 // todo: reorganize examples so that we can run them too
 check {
@@ -444,16 +449,16 @@ allprojects {
         tasks.withType(GroovyCompile) {
             logger.info("Building ${project.name}:${name} with InvokeDynamic 
support activated")
             groovyOptions.optimizationOptions.indy = true
-            sourceCompatibility = 1.7
-            targetCompatibility = 1.7
+            sourceCompatibility = 1.8
+            targetCompatibility = 1.8
         }
         tasks.withType(JavaCompile) {
             if (project.name=='performance') {
                 sourceCompatibility = 1.8
                 targetCompatibility = 1.8
             } else {
-                sourceCompatibility = 1.7
-                targetCompatibility = 1.7
+                sourceCompatibility = 1.8
+                targetCompatibility = 1.8
             }
         }
         jar {
@@ -473,11 +478,11 @@ task checkCompatibility {
     }
 }
 
-if (!JavaVersion.current().java7Compatible) {
+if (!JavaVersion.current().java8Compatible) {
     logger.lifecycle '''
     **************************************** WARNING 
********************************************
     ******   You are running the build with an older JDK. NEVER try to release 
with 1.6.   ******
-    ******   You must use a JDK 1.7+ in order to compile all features of the 
language.     ******
+    ******   You must use a JDK 1.8+ in order to compile all features of the 
language.     ******
     
*********************************************************************************************
 '''
 }

Reply via email to