[ 
https://issues.apache.org/jira/browse/GUACAMOLE-675?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16712864#comment-16712864
 ] 

Michael Jumper commented on GUACAMOLE-675:
------------------------------------------

{quote}
Updating my guacamole test server running with github version 1.0.0. previously 
updated few month ago.
{quote}

Until a tag is created, a release announcement is made, etc., there is no 1.0.0 
release and anything you are building from git is under-development code. The 
only exception to this are tags in git which point to the final source of a 
release (like the "0.9.14" tag).

{quote}
I just running a new update with the lastest github version, everything during 
the update works fine except one thing i did notice previously during other 
github upgrade version from 1.0.0 to 1.0.0.

Upgrade mysql schema database encoutered an error due guacamole table existing.
{quote}

If you applied under-development schema changes to your database from months 
ago, then your schema no longer matches the schema of any release and you will 
need to drop and recreate your database from scratch.

The upgrade scripts are incremental relative to releases. They apply the 
necessary schema changes to upgrade the database from the schema used by a 
previous release. They do not upgrade from arbitrary points in time between 
releases.

> Unexpected Internal Error when trying to create a new group
> -----------------------------------------------------------
>
>                 Key: GUACAMOLE-675
>                 URL: https://issues.apache.org/jira/browse/GUACAMOLE-675
>             Project: Guacamole
>          Issue Type: Bug
>          Components: guacamole-auth-jdbc-mysql
>    Affects Versions: 1.0.0
>         Environment: Ubuntu 16.04.3 / guacamole 1.0.0 from GitHub / 
>            Reporter: emma
>            Priority: Minor
>         Attachments: Groups.png, Groups_CatalinaOut.png, 
> Groups_Schema_Update1.0.0to1.0.0.png, Guacamole_db_tables.png
>
>
> Hi,
> Updating my guacamole test server running with github version 1.0.0. 
> previously updated few month ago.
> I just running a new update with the lastest github version, everything 
> during the update works fine except one thing i did notice previously during 
> other github upgrade version from 1.0.0 to 1.0.0.
> Upgrade mysql schema database encoutered an error due guacamole table 
> existing.
> So i guess it is link with the problem during New group creation and 
> "Unexpected Internel Error" cause some table missing in the database.
> !Groups.png!!Groups_Schema_Update1.0.0to1.0.0.png!
> What i get during my upgrade procedure when i try to update the schema
> !Groups_CatalinaOut.png!
> In catalina.out log about SQL error.
> I am not surprise that some table doesn't exist as i cannot update mysql 
> database schema still in 1.0.0 (from previous upgrade) so im not sure the 
> schema upgrade is complete from 1.0.0 to 1.0.0 with Group management ?
> !Guacamole_db_tables.png!
> It seems guacamole_user_group_attribute table is missing ?
> Well im not an expert but group creation not working for now.
> Regards



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Reply via email to