[ 
https://issues.apache.org/jira/browse/HUDI-6020?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

Raymond Xu updated HUDI-6020:
-----------------------------
    Description: 
should deprecate repeated configs in S3EventsHoodieIncrSourceConfig and make 
people use keys in HoodieIncrSourceConfig and CloudSourceConfig going forward

Config key like 
org.apache.hudi.utilities.config.CloudSourceConfig#SPARK_DATASOURCE_OPTIONS 
should also be renamed to something like 
`hoodie.deltastreamer.source.cloud_incr.spark.datasource.options`

  was:should deprecate repeated configs in S3EventsHoodieIncrSourceConfig and 
make people use keys in HoodieIncrSourceConfig going forward


> Consolidate S3EventsHoodieIncrSourceConfig into HoodieIncrSourceConfig
> ----------------------------------------------------------------------
>
>                 Key: HUDI-6020
>                 URL: https://issues.apache.org/jira/browse/HUDI-6020
>             Project: Apache Hudi
>          Issue Type: Improvement
>            Reporter: Raymond Xu
>            Priority: Major
>
> should deprecate repeated configs in S3EventsHoodieIncrSourceConfig and make 
> people use keys in HoodieIncrSourceConfig and CloudSourceConfig going forward
> Config key like 
> org.apache.hudi.utilities.config.CloudSourceConfig#SPARK_DATASOURCE_OPTIONS 
> should also be renamed to something like 
> `hoodie.deltastreamer.source.cloud_incr.spark.datasource.options`



--
This message was sent by Atlassian Jira
(v8.20.10#820010)

Reply via email to