[
https://issues.apache.org/jira/browse/HUDI-7419?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]
Vinish Reddy closed HUDI-7419.
------------------------------
Resolution: Done
> Remove duplicate code for getFileFormat and Refactor filter methods for
> S3/GCS sources
> --------------------------------------------------------------------------------------
>
> Key: HUDI-7419
> URL: https://issues.apache.org/jira/browse/HUDI-7419
> Project: Apache Hudi
> Issue Type: Improvement
> Components: deltastreamer
> Reporter: Vinish Reddy
> Assignee: Vinish Reddy
> Priority: Minor
>
> The logic to retrieve the data file format is duplicated across both sources,
> in S3 source we are handling the new config change properly but we are doing
> it for GCS, moved it to a common class to reduce the duplicate code blocks.
> Refactored the generateFilter methods to public static methods for S3/GCS
> sources.
--
This message was sent by Atlassian Jira
(v8.20.10#820010)