deepakpanda93 commented on issue #14392: URL: https://github.com/apache/hudi/issues/14392#issuecomment-5114565658
This issue was reviewed as part of the JIRA-migrated backlog triage. This is a broadly-scoped refactoring request ([HUDI-488](https://issues.apache.org/jira/browse/HUDI-488)) with no concrete scope, no linked PR, and no activity in either JIRA or GitHub for over three years (last JIRA update 2023-03-10). In the meantime the `hudi-utilities` source hierarchy has been consolidated along the lines this issue asked for. On `release-1.2.0`, `Source<T>` provides a `final fetchNext()` template method with `fetchNewData()` / `translateCheckpoint()` hooks, and shared base classes factor out the duplicated logic - `KafkaSource` (shared by `AvroKafkaSource` / `JsonKafkaSource` / `ProtoKafkaSource`) and `KinesisSource` (shared by `JsonKinesisSource`). Closing as stale. If specific duplication remains in a particular `Source` subclass, please open a fresh issue naming the classes and the duplicated logic. -- This is an automated message from the Apache Git Service. To respond to the message, please log on to GitHub and use the URL above to go to the specific comment. To unsubscribe, e-mail: [email protected] For queries about this service, please contact Infrastructure at: [email protected]
