rangareddy commented on issue #17344:
URL: https://github.com/apache/hudi/issues/17344#issuecomment-5351235719

   This issue was reviewed as part of the JIRA-migrated backlog triage 
(HUDI-8752).
   
   **Findings: not done. The merger surface is still large and inconsistently 
named.**
   
   Sampling the current class names on `master`:
   
   - `hudi-common` - `HoodieRecordMerger`, `HoodieAvroRecordMerger`, 
`HoodiePreCombineAvroRecordMerger`, `OverwriteWithLatestMerger` (note: no 
`Record` in the name, unlike its siblings), `BufferedRecordMerger`, 
`BufferedRecordMergerFactory`
   - `hudi-spark-client` - `HoodieSparkRecordMerger`, 
`DefaultSparkRecordMerger`, `OverwriteWithLatestSparkRecordMerger`
   - `hudi-flink-client` - `HoodieFlinkRecordMerger`, 
`CommitTimeFlinkRecordMerger`, `EventTimeFlinkRecordMerger`, 
`PartialUpdateFlinkRecordMerger`
   
   One concrete item to start with: 
`hudi-client/hudi-flink-client/src/main/java/org/apache/hudi/util/` contains 
**both** `WriteStatMerger.java` and `WriteStatusMerger.java`. Two classes whose 
names differ by three characters, in the same package, is exactly the kind of 
thing this ticket exists to remove, and it is a self-contained first step.
   
   Beyond that, the naming is inconsistent in a way worth settling explicitly: 
some implementations are `<Something>RecordMerger`, one is `<Something>Merger`, 
and the `Buffered*` family is a different abstraction layer sharing the same 
suffix.
   
   Keeping this open.
   


-- 
This is an automated message from the Apache Git Service.
To respond to the message, please log on to GitHub and use the
URL above to go to the specific comment.

To unsubscribe, e-mail: [email protected]

For queries about this service, please contact Infrastructure at:
[email protected]

Reply via email to