deepakpanda93 commented on issue #14612:
URL: https://github.com/apache/hudi/issues/14612#issuecomment-5436323167

   This issue was reviewed as part of the JIRA-migrated backlog triage and is 
being closed as stale.
   
   The description is only a pointer to review comment `r927125192` on PR #5523 
- and that PR is `[HUDI-4039]`, the
   review that created this ticket rather than a fix for it. The ask, "vet all 
critical code paths for double-checked
   locking", never lists the paths or says what counts as vetted, and the JIRA 
has not moved since 2023-03-10.
   
   The one site the review actually named, 
`BuiltinKeyGenerator.tryInitRowAccessor`, still has that shape today, but its
   field is `volatile`, so the pattern is safe under the Java memory model. If 
a specific unsafe site is found, please
   open an issue naming it.


-- 
This is an automated message from the Apache Git Service.
To respond to the message, please log on to GitHub and use the
URL above to go to the specific comment.

To unsubscribe, e-mail: [email protected]

For queries about this service, please contact Infrastructure at:
[email protected]

Reply via email to