Repository: jena
Updated Branches:
  refs/heads/master 48c6dc645 -> 22933e357


Apache parent POM v19


Project: http://git-wip-us.apache.org/repos/asf/jena/repo
Commit: http://git-wip-us.apache.org/repos/asf/jena/commit/6b850b1e
Tree: http://git-wip-us.apache.org/repos/asf/jena/tree/6b850b1e
Diff: http://git-wip-us.apache.org/repos/asf/jena/diff/6b850b1e

Branch: refs/heads/master
Commit: 6b850b1e2dd492d875b6b42ed2f7389f0f81bf71
Parents: 161c03e
Author: Andy Seaborne <a...@apache.org>
Authored: Fri Feb 2 16:28:06 2018 +0000
Committer: Andy Seaborne <a...@apache.org>
Committed: Fri Feb 9 22:39:06 2018 +0000

----------------------------------------------------------------------
 jena-elephas/pom.xml | 22 ++++++++++++++++++++++
 jena-text-es/pom.xml | 10 ++++++++++
 pom.xml              |  7 +++++--
 3 files changed, 37 insertions(+), 2 deletions(-)
----------------------------------------------------------------------


http://git-wip-us.apache.org/repos/asf/jena/blob/6b850b1e/jena-elephas/pom.xml
----------------------------------------------------------------------
diff --git a/jena-elephas/pom.xml b/jena-elephas/pom.xml
index f1bec83..c2c71c4 100644
--- a/jena-elephas/pom.xml
+++ b/jena-elephas/pom.xml
@@ -58,6 +58,28 @@ limitations under the License.
     </profile>
   </profiles>
 
+  <build>
+    <plugins>
+      <plugin>
+        <groupId>org.apache.maven.plugins</groupId>
+        <artifactId>maven-enforcer-plugin</artifactId>
+        <!-- skip does not seem to skip -->
+        <executions>
+          <execution>
+            <id>enforce</id>
+            <phase/>
+          </execution>
+        </executions>
+        <configuration>
+          <!-- The Hadoop dependency has inconsistent dependencies -->
+          <!-- Really want to just turn off <dependencyConvergence/> -->
+          <skip>true</skip>
+          <fail>false</fail>
+        </configuration>
+      </plugin>
+    </plugins>
+  </build>
+
   <dependencyManagement>
     <dependencies>
       <!-- Hadoop Dependencies -->

http://git-wip-us.apache.org/repos/asf/jena/blob/6b850b1e/jena-text-es/pom.xml
----------------------------------------------------------------------
diff --git a/jena-text-es/pom.xml b/jena-text-es/pom.xml
index 71d2b29..e547f4e 100644
--- a/jena-text-es/pom.xml
+++ b/jena-text-es/pom.xml
@@ -58,6 +58,16 @@
     <dependency>
       <groupId>org.elasticsearch.client</groupId>
       <artifactId>transport</artifactId>
+      <exclusions>
+        <!-- Take "jackson" that comes via jsonld-java
+             At Jena 3.7.0 that is jsonld-java v0.11.1 depends on jackson 2.9.0
+             whereas elasticsearch depends on jackson 2.8.6
+        -->
+        <exclusion>
+          <groupId>com.fasterxml.jackson.core</groupId>
+          <artifactId>jackson-core</artifactId>
+        </exclusion>
+      </exclusions>
     </dependency>
 
     <dependency>

http://git-wip-us.apache.org/repos/asf/jena/blob/6b850b1e/pom.xml
----------------------------------------------------------------------
diff --git a/pom.xml b/pom.xml
index 2ccd2f8..79e1ff7 100644
--- a/pom.xml
+++ b/pom.xml
@@ -28,7 +28,7 @@
   <parent>
     <groupId>org.apache</groupId>
     <artifactId>apache</artifactId>
-    <version>18</version>
+    <version>19</version>
   </parent>
 
   <licenses>
@@ -252,7 +252,9 @@
         <module>jena-fuseki1</module>
         <module>jena-csv</module>
         <module>jena-sdb</module>
-        <module>jena-maven-tools</module>
+        <!-- apache-19 breaks this
+          <module>jena-maven-tools</module>
+        -->
 
         <!-- Other -->
         <module>jena-permissions</module>
@@ -581,6 +583,7 @@
             </goals>
             <configuration combine.self="override">
               <rules>
+                <dependencyConvergence/>
                 <requireJavaVersion>
                   <version>1.8.0</version>
                 </requireJavaVersion>

Reply via email to