This is an automated email from the ASF dual-hosted git repository.

ijuma pushed a commit to branch 1.1
in repository https://gitbox.apache.org/repos/asf/kafka.git

commit 3a5d86e3d14d0c72750cf52b73c609bbd13c394a
Author: Ismael Juma <ism...@juma.me.uk>
AuthorDate: Thu Mar 22 22:01:51 2018 -0700

    MINOR: Java 9/10 fixes, gradle and minor deps update (#4725)
    
    * Added dependencies so that Trogdor and Connect work with Java 9 and 10
    * Updated Jacoco to 0.8.1 so that it works with Java 10
    * Updated Gradle to 4.6
    * A few minor version bumps (not related to Java9/10 fixes)
    
    I tested manually that we can run ./gradlew test with Java 10
    after these changes. There are test failures as EasyMock
    and PowerMock will have to be updated to use a newer
    ASM version. But compiling successfully and most tests
    passing is progress. :)
    
    I also tested manually that Trogdor can be started with Java 10.
    It previously failed with a ClassNotFoundError.
    
    Reviewers: Jason Gustafson <ja...@confluent.io>
---
 build.gradle               | 10 +++++++---
 gradle/dependencies.gradle | 16 ++++++++++------
 2 files changed, 17 insertions(+), 9 deletions(-)

diff --git a/build.gradle b/build.gradle
index f4d1fb3..a152b1e 100644
--- a/build.gradle
+++ b/build.gradle
@@ -28,7 +28,7 @@ buildscript {
     classpath 'com.github.ben-manes:gradle-versions-plugin:0.17.0'
     classpath 'org.scoverage:gradle-scoverage:2.1.0'
     classpath 'com.github.jengelman.gradle.plugins:shadow:2.0.2'
-    classpath 'org.owasp:dependency-check-gradle:3.0.2'
+    classpath 'org.owasp:dependency-check-gradle:3.1.1'
   }
 }
 
@@ -79,7 +79,7 @@ allprojects {
 }
 
 ext {
-  gradleVersion = "4.5.1"
+  gradleVersion = "4.6"
   buildVersionFileName = "kafka-version.properties"
 
   maxPermSizeArgs = []
@@ -386,7 +386,7 @@ subprojects {
   if (it.path != ':core') {
 
     jacoco {
-      toolVersion = "0.8.0"
+      toolVersion = "0.8.1"
     }
 
     // NOTE: Jacoco Gradle plugin does not support "offline instrumentation" 
this means that classes mocked by PowerMock
@@ -874,6 +874,8 @@ project(':tools') {
 
     compile libs.jacksonJaxrsJsonProvider
     compile libs.jerseyContainerServlet
+    compile libs.jaxbApi // Jersey dependency that was available in the JDK 
before Java 9
+    compile libs.activation // Jersey dependency that was available in the JDK 
before Java 9
     compile libs.jettyServer
     compile libs.jettyServlet
     compile libs.jettyServlets
@@ -1263,6 +1265,8 @@ project(':connect:runtime') {
 
     compile libs.jacksonJaxrsJsonProvider
     compile libs.jerseyContainerServlet
+    compile libs.jaxbApi // Jersey dependency that was available in the JDK 
before Java 9
+    compile libs.activation // Jersey dependency that was available in the JDK 
before Java 9
     compile libs.jettyServer
     compile libs.jettyServlet
     compile libs.jettyServlets
diff --git a/gradle/dependencies.gradle b/gradle/dependencies.gradle
index d82ec4b..c4f80b7 100644
--- a/gradle/dependencies.gradle
+++ b/gradle/dependencies.gradle
@@ -47,17 +47,19 @@ if (hasProperty('scalaVersion')) {
 versions["baseScala"] = versions.scala.substring(0, 
versions.scala.lastIndexOf("."))
 
 versions += [
+  activation: "1.1.1",
   apacheda: "1.0.0",
   apacheds: "2.0.0-M24",
   argparse4j: "0.7.0",
-  bcpkix: "1.58",
+  bcpkix: "1.59",
   easymock: "3.5.1",
   jackson: "2.9.4",
   jetty: "9.2.24.v20180105",
   jersey: "2.25.1",
-  jmh: "1.19",
+  jmh: "1.20",
   log4j: "1.2.17",
-  scalaLogging: "3.7.2",
+  scalaLogging: "3.8.0",
+  jaxb: "2.3.0",
   jopt: "5.0.4",
   junit: "4.12",
   kafka_0100: "0.10.0.1",
@@ -65,23 +67,24 @@ versions += [
   kafka_0102: "0.10.2.1",
   kafka_0110: "0.11.0.2",
   kafka_10: "1.0.1",
-  lz4: "1.4",
+  lz4: "1.4.1",
   metrics: "2.2.0",
   // PowerMock 1.x doesn't support Java 9, so use PowerMock 2.0.0 beta
   powermock: "2.0.0-beta.5",
   reflections: "0.9.11",
   rocksDB: "5.7.3",
-  scalatest: "3.0.4",
+  scalatest: "3.0.5",
   scoverage: "1.3.1",
   slf4j: "1.7.25",
   snappy: "1.1.7.1",
   zkclient: "0.10",
   zookeeper: "3.4.10",
   jfreechart: "1.0.0",
-  mavenArtifact: "3.5.2"
+  mavenArtifact: "3.5.3"
 ]
 
 libs += [
+  activation: "javax.activation:activation:$versions.activation",
   argparse4j: "net.sourceforge.argparse4j:argparse4j:$versions.argparse4j",
   apacheda: "org.apache.directory.api:api-all:$versions.apacheda",
   apachedsCoreApi: 
"org.apache.directory.server:apacheds-core-api:$versions.apacheds",
@@ -96,6 +99,7 @@ libs += [
   easymock: "org.easymock:easymock:$versions.easymock",
   jacksonDatabind: 
"com.fasterxml.jackson.core:jackson-databind:$versions.jackson",
   jacksonJaxrsJsonProvider: 
"com.fasterxml.jackson.jaxrs:jackson-jaxrs-json-provider:$versions.jackson",
+  jaxbApi: "javax.xml.bind:jaxb-api:$versions.jaxb",
   jettyServer: "org.eclipse.jetty:jetty-server:$versions.jetty",
   jettyClient: "org.eclipse.jetty:jetty-client:$versions.jetty",
   jettyServlet: "org.eclipse.jetty:jetty-servlet:$versions.jetty",

-- 
To stop receiving notification emails like this one, please contact
ij...@apache.org.

Reply via email to