This is an automated email from the ASF dual-hosted git repository.

ffang pushed a commit to branch master
in repository https://gitbox.apache.org/repos/asf/karaf.git


The following commit(s) were added to refs/heads/master by this push:
     new 1c2b4eb  [KARAF-5695]Starting Karaf Container 4.2.0 in Ubuntu 17.10 
with OpenJDK 9 fails
1c2b4eb is described below

commit 1c2b4eb19a884874e9d20ced42078164c8aac579
Author: Freeman Fang <freeman.f...@gmail.com>
AuthorDate: Wed Apr 11 21:00:41 2018 +0800

    [KARAF-5695]Starting Karaf Container 4.2.0 in Ubuntu 17.10 with OpenJDK 9 
fails
---
 assemblies/features/base/src/main/filtered-resources/resources/bin/inc | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git 
a/assemblies/features/base/src/main/filtered-resources/resources/bin/inc 
b/assemblies/features/base/src/main/filtered-resources/resources/bin/inc
index 8e73df2..58c3ce3 100644
--- a/assemblies/features/base/src/main/filtered-resources/resources/bin/inc
+++ b/assemblies/features/base/src/main/filtered-resources/resources/bin/inc
@@ -208,7 +208,7 @@ detectJVM() {
 }
 
 checkJvmVersion() {
-    VERSION=$("${JAVA}" -version 2>&1 | awk -F '"' '/version/ {print $2}' | 
sed -e 's/_.*//g; s/^1\.//g ; s/\..*//g;')
+    VERSION=$("${JAVA}" -version 2>&1 | awk -F '"' '/version/ {print $2}' | 
sed -e 's/_.*//g; s/^1\.//g ; s/\..*//g; s/-.*//g;')
     if [ "${VERSION}" -lt "8" ]; then
         die "JVM must be greater than 1.8"
     fi

-- 
To stop receiving notification emails like this one, please contact
ff...@apache.org.

Reply via email to