This is an automated email from the ASF dual-hosted git repository.

jbonofre pushed a commit to branch karaf-4.2.x
in repository https://gitbox.apache.org/repos/asf/karaf.git


The following commit(s) were added to refs/heads/karaf-4.2.x by this push:
     new e3fd6e7  [KARAF-6370] Add human readable output in the static installer
e3fd6e7 is described below

commit e3fd6e755f3aecaa8253eab18ec68cecd5935215
Author: Jean-Baptiste Onofré <jbono...@apache.org>
AuthorDate: Sat Sep 7 07:39:52 2019 +0200

    [KARAF-6370] Add human readable output in the static installer
    
    (cherry picked from commit 9e342865a05b8198eb63ab7cbdd5c724a3d6a3a0)
---
 .../apache/karaf/features/internal/service/StaticInstallSupport.java    | 2 ++
 1 file changed, 2 insertions(+)

diff --git 
a/features/core/src/main/java/org/apache/karaf/features/internal/service/StaticInstallSupport.java
 
b/features/core/src/main/java/org/apache/karaf/features/internal/service/StaticInstallSupport.java
index 30471a4..a87e029 100644
--- 
a/features/core/src/main/java/org/apache/karaf/features/internal/service/StaticInstallSupport.java
+++ 
b/features/core/src/main/java/org/apache/karaf/features/internal/service/StaticInstallSupport.java
@@ -42,11 +42,13 @@ public abstract class StaticInstallSupport implements 
BundleInstallSupport {
 
     @Override
     public void updateBundle(Bundle bundle, String uri, InputStream is) throws 
BundleException {
+        System.err.println("Update bundle is not supported in the static 
installer");
         throw new UnsupportedOperationException();
     }
 
     @Override
     public void uninstall(Bundle bundle) throws BundleException {
+        System.err.println("Uninstall bundle is not supported in the static 
installer");
         throw new UnsupportedOperationException();
     }
 

Reply via email to