thiagoelg opened a new issue, #3840: URL: https://github.com/apache/incubator-kie-tools/issues/3840
This task aims to define the scripts' names and functionalities. For example: - Every buildable package should have a `build:dev` and `build:prod` script, the built files should be inside `<package_name>/dist`; - Every unit testable package should have a `test` script, test results should be stored in `<package_name>/dist-tests`; and so on... It's also expected to have an execution order defined. For example: 1. Install dependencies; 2. Build; 3. Test; 4. and so on... This is important so that our monorepo is more readable and manageable and makes it easier for future improvements, such as build and test caches. -- This is an automated message from the Apache Git Service. To respond to the message, please log on to GitHub and use the URL above to go to the specific comment. To unsubscribe, e-mail: [email protected] For queries about this service, please contact Infrastructure at: [email protected] --------------------------------------------------------------------- To unsubscribe, e-mail: [email protected] For additional commands, e-mail: [email protected]
