Repository: kudu
Updated Branches:
  refs/heads/master d1d7572b3 -> c61ed9b3f


[Java] Upgrade Dependencies

Upgrades the Java dependencies and Gradle versions.

Maintenance version upgrades:
- Hive 2.3.0 -> 2.3.2
- Scala 2.11.11 -> 2.11.12
- ScalaTest 3.0.3 -> 3.0.5
- Spark 2.2.0 -> 2.2.1

Minor version upgrades:
- CommonsIo 2.5 -> 2.6
- Guava 20.0 -> 24.0-android (Java 1.7 compatible)
- Hadoop 2.8.1 -> 2.9.0
- Mockito 2.8.47 -> 2.15.0
- Protobuf 3.4.0 -> 3.5.1
- Yetus 0.5.0 -> 0.7.0

Gradle upgrades:
- Gradle 4.2.1 -> 4.5.1
- gradle-avro-plugin 0.9.0 -> 0.14.0
- gradle-versions-plugin 0.15.0 -> 0.17.0
- shadow 2.0.1 -> 2.0.2
- protobuf-gradle-plugin 0.8.2 -> 0.8.4
- nebula-clojure-plugin 4.1.0 -> 5.0.6
- gradle-animalsniffer-plugin 1.4.2 -> 1.4.3

Change-Id: Ibfc7edfd8e703e59530063fca6894b019cc00a7a
Reviewed-on: http://gerrit.cloudera.org:8080/9284
Tested-by: Kudu Jenkins
Reviewed-by: Todd Lipcon <t...@apache.org>


Project: http://git-wip-us.apache.org/repos/asf/kudu/repo
Commit: http://git-wip-us.apache.org/repos/asf/kudu/commit/306c86a3
Tree: http://git-wip-us.apache.org/repos/asf/kudu/tree/306c86a3
Diff: http://git-wip-us.apache.org/repos/asf/kudu/diff/306c86a3

Branch: refs/heads/master
Commit: 306c86a36513dfa1a6dc647418937df847c66f71
Parents: d1d7572
Author: Grant Henke <granthe...@gmail.com>
Authored: Mon Feb 12 10:59:49 2018 -0600
Committer: Todd Lipcon <t...@apache.org>
Committed: Mon Feb 12 20:24:59 2018 +0000

----------------------------------------------------------------------
 java/buildSrc/build.gradle      | 12 ++++++------
 java/gradle/dependencies.gradle | 20 ++++++++++----------
 java/gradlew                    |  4 ++--
 java/pom.xml                    | 18 +++++++++---------
 4 files changed, 27 insertions(+), 27 deletions(-)
----------------------------------------------------------------------


http://git-wip-us.apache.org/repos/asf/kudu/blob/306c86a3/java/buildSrc/build.gradle
----------------------------------------------------------------------
diff --git a/java/buildSrc/build.gradle b/java/buildSrc/build.gradle
index 9ab7892..4cd37eb 100644
--- a/java/buildSrc/build.gradle
+++ b/java/buildSrc/build.gradle
@@ -28,11 +28,11 @@ repositories {
 // Manage plugin dependencies since the plugin block can't be used in included 
build scripts yet.
 // For more details see: 
https://docs.gradle.org/current/userguide/plugins.html#plugins_dsl_limitations
 dependencies {
-  compile "com.commercehub.gradle.plugin:gradle-avro-plugin:0.9.0"
-  compile "com.github.ben-manes:gradle-versions-plugin:0.15.0"
-  compile "com.github.jengelman.gradle.plugins:shadow:2.0.1"
-  compile "com.google.protobuf:protobuf-gradle-plugin:0.8.2"
-  compile "com.netflix.nebula:nebula-clojure-plugin:4.1.0"
+  compile "com.commercehub.gradle.plugin:gradle-avro-plugin:0.14.0"
+  compile "com.github.ben-manes:gradle-versions-plugin:0.17.0"
+  compile "com.github.jengelman.gradle.plugins:shadow:2.0.2"
+  compile "com.google.protobuf:protobuf-gradle-plugin:0.8.4"
+  compile "com.netflix.nebula:nebula-clojure-plugin:5.0.6"
   compile "io.spring.gradle:propdeps-plugin:0.0.9.RELEASE"
-  compile "ru.vyarus:gradle-animalsniffer-plugin:1.4.2"
+  compile "ru.vyarus:gradle-animalsniffer-plugin:1.4.3"
 }

http://git-wip-us.apache.org/repos/asf/kudu/blob/306c86a3/java/gradle/dependencies.gradle
----------------------------------------------------------------------
diff --git a/java/gradle/dependencies.gradle b/java/gradle/dependencies.gradle
index 5954018..1dd2afe 100755
--- a/java/gradle/dependencies.gradle
+++ b/java/gradle/dependencies.gradle
@@ -29,30 +29,30 @@ versions += [
     avro           : "1.8.2",
     clojure        : "1.8.0",
     clojureToolsCli: "0.3.5",
-    commonsIo      : "2.5",
+    commonsIo      : "2.6",
     findbugs       : "3.0.1",
     flume          : "1.7.0",
-    gradle         : "4.2.1",
+    gradle         : "4.5.1",
     guava          : "20.0",
-    hadoop         : "2.8.1",
+    hadoop         : "2.9.0",
     hamcrest       : "1.3",
-    hive           : "2.3.0",
+    hive           : "2.3.2",
     jepsen         : "0.1.5",
     jsr305         : "3.0.2",
     junit          : "4.12",
     log4j          : "1.2.17",
-    mockito        : "2.8.47",
+    mockito        : "2.15.0",
     murmur         : "1.0.0",
     netty          : "3.10.6.Final",
     parquet        : "1.9.0",
     pmd            : "5.8.1",
-    protobuf       : "3.4.0",
-    scala          : "2.11.11",
-    scalatest      : "3.0.3",
+    protobuf       : "3.5.1",
+    scala          : "2.11.12",
+    scalatest      : "3.0.5",
     slf4j          : "1.7.25",
-    spark          : "2.2.0",
+    spark          : "2.2.1",
     sparkAvro      : "3.2.0",
-    yetus          : "0.5.0"
+    yetus          : "0.7.0"
 ]
 
 // Log the Gradle version used vs defined.

http://git-wip-us.apache.org/repos/asf/kudu/blob/306c86a3/java/gradlew
----------------------------------------------------------------------
diff --git a/java/gradlew b/java/gradlew
index 8c9dd31..5751ddd 100755
--- a/java/gradlew
+++ b/java/gradlew
@@ -81,10 +81,10 @@ esac
 
 mkdir -p $APP_HOME/gradle/wrapper
 if [ ! -e $APP_HOME/gradle/wrapper/gradle-wrapper.jar ]; then
-   curl -o $APP_HOME/gradle/wrapper/gradle-wrapper.jar 
https://raw.githubusercontent.com/gradle/gradle/v4.2.1/gradle/wrapper/gradle-wrapper.jar
+   curl -o $APP_HOME/gradle/wrapper/gradle-wrapper.jar 
https://raw.githubusercontent.com/gradle/gradle/v4.5.1/gradle/wrapper/gradle-wrapper.jar
 fi
 if [ ! -e $APP_HOME/gradle/wrapper/gradle-wrapper.properties ]; then
-   curl -o $APP_HOME/gradle/wrapper/gradle-wrapper.properties 
https://raw.githubusercontent.com/gradle/gradle/v4.2.1/gradle/wrapper/gradle-wrapper.properties
+   curl -o $APP_HOME/gradle/wrapper/gradle-wrapper.properties 
https://raw.githubusercontent.com/gradle/gradle/v4.5.1/gradle/wrapper/gradle-wrapper.properties
 fi
 
 CLASSPATH=$APP_HOME/gradle/wrapper/gradle-wrapper.jar

http://git-wip-us.apache.org/repos/asf/kudu/blob/306c86a3/java/pom.xml
----------------------------------------------------------------------
diff --git a/java/pom.xml b/java/pom.xml
index 04afbed..c798530 100644
--- a/java/pom.xml
+++ b/java/pom.xml
@@ -69,30 +69,30 @@
         <avro.version>1.8.2</avro.version>
         <clojure.tools.version>0.3.5</clojure.tools.version>
         <clojure.version>1.8.0</clojure.version>
-        <commons-io.version>2.5</commons-io.version>
+        <commons-io.version>2.6</commons-io.version>
         <flume.version>1.7.0</flume.version>
         <guava.version>20.0</guava.version>
-        <hadoop.version>2.8.1</hadoop.version>
+        <hadoop.version>2.9.0</hadoop.version>
         <hamcrest-core.version>1.3</hamcrest-core.version>
-        <hive.version>2.3.0</hive.version>
+        <hive.version>2.3.2</hive.version>
         <jepsen.version>0.1.5</jepsen.version>
         <jsr305.version>3.0.2</jsr305.version>
         <junit.version>4.12</junit.version>
         <log4j.version>1.2.17</log4j.version>
-        <mockito-core.version>2.8.47</mockito-core.version>
+        <mockito-core.version>2.15.0</mockito-core.version>
         <murmur.version>1.0.0</murmur.version>
         <netty.version>3.10.6.Final</netty.version>
         <parquet.version>1.9.0</parquet.version>
-        <protobuf.version>3.4.0</protobuf.version>
+        <protobuf.version>3.5.1</protobuf.version>
         <slf4j.version>1.7.25</slf4j.version>
         <sparkavro.version>3.2.0</sparkavro.version>
-        <yetus.version>0.4.0</yetus.version>
+        <yetus.version>0.7.0</yetus.version>
 
         <!-- Scala Library dependencies -->
         <scala.binary.version>2.11</scala.binary.version>
-        <scala.version>2.11.11</scala.version>
-        <scalatest.version>3.0.3</scalatest.version>
-        <spark.version>2.1.1</spark.version>
+        <scala.version>2.11.12</scala.version>
+        <scalatest.version>3.0.5</scalatest.version>
+        <spark.version>2.2.1</spark.version>
         <spark.version.label>spark2</spark.version.label>
 
         <!-- Misc variables -->

Reply via email to