Dear Wiki user, You have subscribed to a wiki page or wiki category on "Libcloud Wiki" for change notification.
The "DNS API proposal" page has been changed by TomazMuraus: http://wiki.apache.org/libcloud/DNS%20API%20proposal?action=diff&rev1=1&rev2=2 == Naming == - * '''Zone''' - represents a DNS zone. It can contain one or more hosts (records). + * '''Zone''' - represents a DNS zone. It can contain one or more records (records). - * '''Host''' - represents a DNS host / resource / record. + * '''Record''' - represents a DNS record / resource / host. * '''RecordType''' - DNS record type (A, AAAA, MX, ....). - - I'm not totally sure about "Host", better generic name would probably be "Record". Opinions? == Base API == === DNSDriver === * ''list_zones()'' - Return a list of zones. - * ''list_hosts()'' - Return a list of hosts for the provided zone. + * ''list_records()'' - Return a list of records for the provided zone. + * ''get_zone(zone_id)'' - Return Zone instance + * ''get_record(zone_id, record_id)'' - Return Record instance * ''create_zone(type='master', ttl=None, extra=None)'' - Create a new zone. - * ''create_host(name, type, data, extra=None)'' - Create a new host record. + * ''create_record(name, type, data, extra=None)'' - Create a new record record. - * ''update_host(host, name, type, data, extra)'' - Update an existing host record. + * ''update_record(record, name, type, data, extra)'' - Update an existing record record. * ''delete_zone(zone)'' - Delete a zone. - * ''delete_host(host)'' - Delete a host record. + * ''delete_record(record)'' - Delete a record record. === Zone === - * ''list_hosts()'' - List host records for this zone. + * ''list_records()'' - List record for this zone. * ''delete()'' - Delete a zone. - === Host === + === Record === - * ''update(name, type, data, extra)'' - Update host record. + * ''update(name, type, data, extra)'' - Update record. - * ''delete()'' - Delete a host record. + * ''delete()'' - Delete a record. - https://svn.apache.org/viewvc/libcloud/trunk/libcloud/dns/base.py?view=markup&pathrev=1169490 + https://svn.apache.org/viewvc/libcloud/trunk/libcloud/dns/base.py?view=markup == Documentation for existing DNS APIs ==
