stmatengss opened a new issue #7362: import mxnet errors
URL: https://github.com/apache/incubator-mxnet/issues/7362
 
 
   ## Description
   If I use pip(which is provided by OS, is not the version through get-pip.py 
script) to install mxnet, there are some errors occur when I run "import mxnet 
as mx".
   
   ## Environment info
   Operating System:
   Ubuntu 14.04 
   
   Compiler:
   gcc 4.8.4
   
   Package used (Python/R/Scala/Julia):
   Python
   
   MXNet version:
   0.10.0.post2
   
   MXNet commit hash (`git rev-parse HEAD`):
   
   Python version and distribution:
   python 2.7
   
   
   ## Error Message:
   
   ---------------------------------------------------------------------------  
                           
   OSError                                   Traceback (most recent call last)  
                           
   <ipython-input-1-cb88d04c42ec> in <module>()                                 
                           
   ----> 1 import mxnet as mx                                                   
                           
                                                                                
                           
   /usr/local/lib/python2.7/dist-packages/mxnet/__init__.py in <module>()       
                           
         5                                                                      
                           
         6 from .context import Context, current_context, cpu, gpu              
                           
   ----> 7 from .base import MXNetError                                         
                           
         8 from . import base                                                   
                           
         9 from . import contrib                                                
                           
                                                                                
                           
   /usr/local/lib/python2.7/dist-packages/mxnet/base.py in <module>()           
                           
        50 __version__ = libinfo.__version__                                    
                           
        51 # library instance of mxnet                                          
                           
   ---> 52 _LIB = _load_lib()                                                   
                           
        53                                                                      
                           
        54 # type definitions                                                   
                           
                                                                                
                           
   /usr/local/lib/python2.7/dist-packages/mxnet/base.py in _load_lib()          
                           
        42     """Load libary by searching possible path."""                    
                           
        43     lib_path = libinfo.find_lib_path()                               
                           
   ---> 44     lib = ctypes.CDLL(lib_path[0], ctypes.RTLD_GLOBAL)               
                           
        45     # DMatrix functions                                              
                           
        46     lib.MXGetLastError.restype = ctypes.c_char_p                     
                           
                                                                                
                           
   /usr/lib/python2.7/ctypes/__init__.pyc in __init__(self, name, mode, handle, 
use_errno, use_last_error) 
       363                                                                      
                           
       364         if handle is None:                                           
                           
   --> 365             self._handle = _dlopen(self._name, mode)                 
                           
       366         else:                                                        
                           
       367             self._handle = handle                                    
                           
                                                                                
                           
   OSError: /usr/local/lib/python2.7/dist-packages/mxnet/libmxnet.so: invalid 
ELF header                   
   
   
   ## Minimum reproducible example
   I don't use `wget https://bootstrap.pypa.io/get-pip.py && sudo python 
get-pip.py`, and I directly use the pip which provided by OS. The pip version 
is `pip-1.5.4`.
   
   
   ## Steps to reproduce
   or if you are running standard examples, please provide the commands you 
have run that lead to the error.
   
   1.
   2.
   3.
   
   ## What have you tried to solve it?
   
   1.
   2.
   3.
   
 
----------------------------------------------------------------
This is an automated message from the Apache Git Service.
To respond to the message, please log on GitHub and use the
URL above to go to the specific comment.
 
For queries about this service, please contact Infrastructure at:
us...@infra.apache.org


With regards,
Apache Git Services

Reply via email to