ptrendx commented on issue #9774: mx.io.ImageRecordIter does not respect dtype 
argument
URL: 
https://github.com/apache/incubator-mxnet/issues/9774#issuecomment-365780010
 
 
   There are few possible explanations.
   The most probable reason is workspace size for convolutions. I tried 
pitching @piiswrong to change the default MXNet's behavior of limiting the 
results of cudnnFind to the ones fitting the workspace, but did not have luck 
with that. Try with MXNET_CUDNN_AUTOTUNE_DEFAULT = 2. 
   Also if you tried benchmarking with real data, make sure you are not limited 
by the IO (you may need to set --data-nthreads to something more than the 
default 4).
   And finally, depthwise convolutions in networks like resnext do not 
currently benefit much from TensorCore, so if that is what you tested, then 
benefit should be small.

----------------------------------------------------------------
This is an automated message from the Apache Git Service.
To respond to the message, please log on GitHub and use the
URL above to go to the specific comment.
 
For queries about this service, please contact Infrastructure at:
us...@infra.apache.org


With regards,
Apache Git Services

Reply via email to