[ 
https://issues.apache.org/jira/browse/NETBEANS-2944?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

Enrico Scantamburlo updated NETBEANS-2944:
------------------------------------------
    Description: 
We have a NetBeans Application based on NetBeans 8.1, we tried to build it on 
NetBeans 9, 10, 11, 11.1 but the compilation failed.

We set the proper NetBeans Platform (8.1) and the correct JDK ( 8 ) but the 
compilation failed complaining that the files that should be generated by the 
@ServiceProvider annotation were not present (maybe also the layer extensions).

 

Eventually we found what the problem was: even if we set the JDK 1.8 as the 
application JDK the NetBeans IDE runs Ant with its default JDK (it was 9 at 
that time). Running the NetBeans IDE with JDK 8 fixed the problem.

  was:
We have a NetBeans Application based on NetBeans 8.1, we tried to build it on 
NetBeans 9, 10, 11, 11.1 but the compiletion failed.

We set the proper NetBeans Platform (8.1) and the correct JDK ( 8 ) but the 
compilation failed complaining that the files that should be generated by the 
@ServiceProvider annotation were not present (maybe also the layer extensions).

 

Eventually we found what the problem was: even if we set the JDK 1.8 as the 
application JDK the NetBeans IDE runs Ant with its default JDK (it was 9 at 
that time).Running the NetBeans IDE with JDK 8 fixed the problem.


> Cannot compile NetBeans Platform Application on Java 9+
> -------------------------------------------------------
>
>                 Key: NETBEANS-2944
>                 URL: https://issues.apache.org/jira/browse/NETBEANS-2944
>             Project: NetBeans
>          Issue Type: Bug
>          Components: projects - Ant
>    Affects Versions: 9.0, 10.0, 11.0, 11.1
>            Reporter: Enrico Scantamburlo
>            Priority: Critical
>
> We have a NetBeans Application based on NetBeans 8.1, we tried to build it on 
> NetBeans 9, 10, 11, 11.1 but the compilation failed.
> We set the proper NetBeans Platform (8.1) and the correct JDK ( 8 ) but the 
> compilation failed complaining that the files that should be generated by the 
> @ServiceProvider annotation were not present (maybe also the layer 
> extensions).
>  
> Eventually we found what the problem was: even if we set the JDK 1.8 as the 
> application JDK the NetBeans IDE runs Ant with its default JDK (it was 9 at 
> that time). Running the NetBeans IDE with JDK 8 fixed the problem.



--
This message was sent by Atlassian Jira
(v8.3.4#803005)

---------------------------------------------------------------------
To unsubscribe, e-mail: commits-unsubscr...@netbeans.apache.org
For additional commands, e-mail: commits-h...@netbeans.apache.org

For further information about the NetBeans mailing lists, visit:
https://cwiki.apache.org/confluence/display/NETBEANS/Mailing+lists

Reply via email to