[ 
https://issues.apache.org/jira/browse/NETBEANS-1269?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16969472#comment-16969472
 ] 

Ciprian Bulboaca commented on NETBEANS-1269:
--------------------------------------------

I can now confirm the fix done as part of 
https://issues.apache.org/jira/browse/NETBEANS-2661 and released with Netbeans 
11.2 fixed the find usages issues we were having! The fix allows us to finally 
migrate all of our projects to Netbeans 11.2. Thank you!

> Find usages is very slow in Netbeans 9.0 & 10.0 and it sits a long time at 
> Initializing data and Usages progress bar, in some cases without showing any 
> progress at all
> -----------------------------------------------------------------------------------------------------------------------------------------------------------------------
>
>                 Key: NETBEANS-1269
>                 URL: https://issues.apache.org/jira/browse/NETBEANS-1269
>             Project: NetBeans
>          Issue Type: Bug
>    Affects Versions: 9.0, 10.0
>         Environment: Netbeans 9.0 based on jdk-10.0.1 on Windows 10 Pro
> Netbeans 10.0 based on OpenJDL11 on Windows 10 Pro
>            Reporter: Ciprian Bulboaca
>            Priority: Critical
>
> Find usages in Netbeans 9.0 is very slow (compared to Netbeans 8.0.2).
> For example, in our large modular project we have, doing a find usages on any 
> method in any class takes a very long time (4-5 minutes) in Netbeans 9.0. For 
> about half the time, Netbeans 9.0 is just sitting at "Initializing data" and 
> for the other half, it is just sitting at Usages progress bar always showing 
> 0% progress! Then, after a long period of waiting, it just shows the results 
> without even updating the progress bar (or at least you can't tell it is 
> updating the progress bar).
> This all behaves normally under Netbeans 8.0.2 where find usages is showing 
> results right away (as it's scanning) and the whole process takes only a few 
> seconds!
> We've tried bumping up the -J-Xmx setting to 1536m in netbeans.conf and 
> although we see the memory allocated is increasing (in Task Manager), 
> Netbeans 9.0 behaves the same way.
> I'm wondering if anybody else is experiencing this. Is there any workaround 
> for this issue? This affects our day to day work very significantly since we 
> rely on fast 'find usages' operations all the time in our analysis & coding 
> work.



--
This message was sent by Atlassian Jira
(v8.3.4#803005)

---------------------------------------------------------------------
To unsubscribe, e-mail: commits-unsubscr...@netbeans.apache.org
For additional commands, e-mail: commits-h...@netbeans.apache.org

For further information about the NetBeans mailing lists, visit:
https://cwiki.apache.org/confluence/display/NETBEANS/Mailing+lists

Reply via email to