[
https://issues.apache.org/jira/browse/NIFI-1488?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15191515#comment-15191515
]
Bryan Bende commented on NIFI-1488:
-----------------------------------
Also wanted to add that putting aside the validation issue, I've been testing
this out and having trouble getting it working...
I have a kerberized hadoop install that I have used for testing the HDFS
processors so I've done the following:
- Started up HBase
- Verified I couldn't do anything from the hbase shell without a ticket
- Got a ticket and created a table
- Went into NiFi and configured the client service with the same keytab and
principal that I just used to create the table and I get:
{code}
Caused by: java.io.IOException: Could not set up IO Streams to 10.0.2.15:16000
at
org.apache.hadoop.hbase.ipc.RpcClientImpl$Connection.setupIOstreams(RpcClientImpl.java:811)
~[na:na]
at
org.apache.hadoop.hbase.ipc.RpcClientImpl$Connection.writeRequest(RpcClientImpl.java:920)
~[na:na]
at
org.apache.hadoop.hbase.ipc.RpcClientImpl$Connection.tracedWriteRequest(RpcClientImpl.java:889)
~[na:na]
at
org.apache.hadoop.hbase.ipc.RpcClientImpl.call(RpcClientImpl.java:1222) ~[na:na]
at
org.apache.hadoop.hbase.ipc.AbstractRpcClient.callBlockingMethod(AbstractRpcClient.java:213)
~[na:na]
... 29 common frames omitted
Caused by: java.lang.RuntimeException: SASL authentication failed. The most
likely cause is missing or invalid credentials. Consider 'kinit'.
at
org.apache.hadoop.hbase.ipc.RpcClientImpl$Connection$1.run(RpcClientImpl.java:710)
~[na:na]
at java.security.AccessController.doPrivileged(Native Method)
~[na:1.7.0_85]
at javax.security.auth.Subject.doAs(Subject.java:415) ~[na:1.7.0_85]
at
org.apache.hadoop.security.UserGroupInformation.doAs(UserGroupInformation.java:1656)
~[na:na]
at
org.apache.hadoop.hbase.ipc.RpcClientImpl$Connection.handleSaslConnectionFailure(RpcClientImpl.java:668)
~[na:na]
at
org.apache.hadoop.hbase.ipc.RpcClientImpl$Connection.setupIOstreams(RpcClientImpl.java:777)
~[na:na]
... 33 common frames omitted
Caused by: javax.security.sasl.SaslException: GSS initiate failed
at
com.sun.security.sasl.gsskerb.GssKrb5Client.evaluateChallenge(GssKrb5Client.java:212)
~[na:1.7.0_85]
at
org.apache.hadoop.hbase.security.HBaseSaslRpcClient.saslConnect(HBaseSaslRpcClient.java:179)
~[na:na]
at
org.apache.hadoop.hbase.ipc.RpcClientImpl$Connection.setupSaslConnection(RpcClientImpl.java:642)
~[na:na]
at
org.apache.hadoop.hbase.ipc.RpcClientImpl$Connection.access$600(RpcClientImpl.java:166)
~[na:na]
at
org.apache.hadoop.hbase.ipc.RpcClientImpl$Connection$2.run(RpcClientImpl.java:769)
~[na:na]
at
org.apache.hadoop.hbase.ipc.RpcClientImpl$Connection$2.run(RpcClientImpl.java:766)
~[na:na]
at java.security.AccessController.doPrivileged(Native Method)
~[na:1.7.0_85]
at javax.security.auth.Subject.doAs(Subject.java:415) ~[na:1.7.0_85]
at
org.apache.hadoop.security.UserGroupInformation.doAs(UserGroupInformation.java:1656)
~[na:na]
at
org.apache.hadoop.hbase.ipc.RpcClientImpl$Connection.setupIOstreams(RpcClientImpl.java:766)
~[na:na]
... 33 common frames omitted
Caused by: org.ietf.jgss.GSSException: No valid credentials provided (Mechanism
level: Failed to find any Kerberos tgt)
at
sun.security.jgss.krb5.Krb5InitCredential.getInstance(Krb5InitCredential.java:147)
~[na:1.7.0_85]
at
sun.security.jgss.krb5.Krb5MechFactory.getCredentialElement(Krb5MechFactory.java:121)
~[na:1.7.0_85]
at
sun.security.jgss.krb5.Krb5MechFactory.getMechanismContext(Krb5MechFactory.java:187)
~[na:1.7.0_85]
at
sun.security.jgss.GSSManagerImpl.getMechanismContext(GSSManagerImpl.java:223)
~[na:1.7.0_85]
at
sun.security.jgss.GSSContextImpl.initSecContext(GSSContextImpl.java:212)
~[na:1.7.0_85]
at
sun.security.jgss.GSSContextImpl.initSecContext(GSSContextImpl.java:179)
~[na:1.7.0_85]
at
com.sun.security.sasl.gsskerb.GssKrb5Client.evaluateChallenge(GssKrb5Client.java:193)
~[na:1.7.0_85]
... 42 common frames omitted
{code}
> Add Kerberos Support to HBase processors
> ----------------------------------------
>
> Key: NIFI-1488
> URL: https://issues.apache.org/jira/browse/NIFI-1488
> Project: Apache NiFi
> Issue Type: Improvement
> Affects Versions: 0.4.0, 0.4.1
> Reporter: Bryan Bende
> Assignee: Ricky Saltzer
> Fix For: 0.6.0
>
> Attachments:
> 0001-NIFI-1488-Adjusting-unused-imports-and-adding-licens.patch
>
>
> Our current HBase integration does not support communicating with a
> Kerberized HBase install. We should support this just like we do for the HDFS
> processors.
--
This message was sent by Atlassian JIRA
(v6.3.4#6332)