This is an automated email from the ASF dual-hosted git repository.

snagel pushed a commit to branch master
in repository https://gitbox.apache.org/repos/asf/nutch.git


The following commit(s) were added to refs/heads/master by this push:
     new 77fe258  NUTCH-2669 Reliable solution for javax.ws packaging.type - 
update org.apache.cxf to drop javax.ws.rs-api dependency
     new fa9f895  Merge pull request #467 from 
sebastian-nagel/NUTCH-2669-javax-ws-packaging-type
77fe258 is described below

commit 77fe25895208768cc9d356221de4681625f0c05d
Author: Sebastian Nagel <sna...@apache.org>
AuthorDate: Fri Aug 30 16:37:08 2019 +0200

    NUTCH-2669 Reliable solution for javax.ws packaging.type
    - update org.apache.cxf to drop javax.ws.rs-api dependency
---
 ivy/ivy.xml                         | 11 +++++------
 ivy/ivysettings.xml                 |  8 --------
 src/plugin/parse-tika/build-ivy.xml |  7 -------
 3 files changed, 5 insertions(+), 21 deletions(-)

diff --git a/ivy/ivy.xml b/ivy/ivy.xml
index e753c6f..2ffeac4 100644
--- a/ivy/ivy.xml
+++ b/ivy/ivy.xml
@@ -80,12 +80,11 @@
                        <exclude module="hadoop-client" />
                </dependency>
 
-               <!--dependency org="org.apache.cxf" name="cxf" rev="3.0.4" 
conf="*->default"/-->
-               <dependency org="org.apache.cxf" name="cxf-rt-frontend-jaxws" 
rev="3.2.7" conf="*->default"/>
-               <dependency org="org.apache.cxf" name="cxf-rt-frontend-jaxrs" 
rev="3.2.7" conf="*->default"/>
-               <dependency org="org.apache.cxf" name="cxf-rt-transports-http" 
rev="3.2.7" conf="*->default"/>
-               <dependency org="org.apache.cxf" 
name="cxf-rt-transports-http-jetty" rev="3.2.7" conf="*->default"/>
-               <dependency org="org.apache.cxf" name="cxf-rt-rs-client" 
rev="3.2.7" conf="test->default"/>
+               <dependency org="org.apache.cxf" name="cxf-rt-frontend-jaxws" 
rev="3.3.3" conf="*->default"/>
+               <dependency org="org.apache.cxf" name="cxf-rt-frontend-jaxrs" 
rev="3.3.3" conf="*->default"/>
+               <dependency org="org.apache.cxf" name="cxf-rt-transports-http" 
rev="3.3.3" conf="*->default"/>
+               <dependency org="org.apache.cxf" 
name="cxf-rt-transports-http-jetty" rev="3.3.3" conf="*->default"/>
+               <dependency org="org.apache.cxf" name="cxf-rt-rs-client" 
rev="3.3.3" conf="test->default"/>
                <dependency org="com.fasterxml.jackson.core" 
name="jackson-databind" rev="2.9.9" conf="*->default"/>
                <dependency org="com.fasterxml.jackson.core" 
name="jackson-annotations" rev="2.9.9" conf="*->default"/>
                <dependency org="com.fasterxml.jackson.dataformat" 
name="jackson-dataformat-cbor" rev="2.9.9" conf="*->default"/>
diff --git a/ivy/ivysettings.xml b/ivy/ivysettings.xml
index 7a3b949..18038a5 100644
--- a/ivy/ivysettings.xml
+++ b/ivy/ivysettings.xml
@@ -29,14 +29,6 @@
     
value="[organisation]/[module]/[revision]/[module]-[revision](-[classifier])"/>
   <property name="maven2.pattern.ext"
     value="${maven2.pattern}.[ext]"/>
-  <!-- define packaging.type=jar to work around the failing dependency 
download of
-         javax.ws.rs-api.jar
-       required by Tika (1.19 and higher), cf.
-         https://github.com/eclipse-ee4j/jaxrs-api/issues/572
-         https://github.com/jax-rs/api/pull/576
-  -->
-  <property name="packaging.type"
-    value="jar"/>
   <!-- pull in the local repository -->
   <include url="${ivy.default.conf.dir}/ivyconf-local.xml"/>
   <settings defaultResolver="default"/>
diff --git a/src/plugin/parse-tika/build-ivy.xml 
b/src/plugin/parse-tika/build-ivy.xml
index a8a0fe9..738f041 100644
--- a/src/plugin/parse-tika/build-ivy.xml
+++ b/src/plugin/parse-tika/build-ivy.xml
@@ -25,13 +25,6 @@
     <property name="ivy.checksums" value="" />
     <property name="ivy.jar.dir" value="${ivy.home}/lib" />
     <property name="ivy.jar.file" 
value="${ivy.jar.dir}/ivy-${ivy.install.version}.jar" />
-    <!-- define packaging.type=jar to work around the failing dependency 
download of
-           javax.ws.rs-api.jar
-         required by Tika (1.19 and higher), cf.
-           https://github.com/eclipse-ee4j/jaxrs-api/issues/572
-           https://github.com/jax-rs/api/pull/576
-    -->
-    <property name="packaging.type" value="jar"/>
 
     <target name="download-ivy" unless="offline">
 

Reply via email to