Katiyman opened a new issue #2264: Unable to connect to the controller docker 
URL: https://github.com/apache/incubator-openwhisk/issues/2264
 
 
   <!--
   Do NOT share passwords, credentials or other confidential information.
   
   Before creating a new issue, please check if there is one already open that
   fits the defect you are reporting.
   If you open an issue and realize later it is a duplicate of a pre-existing
   open issue, please close yours and add a comment to the other.
   
   Issues can be created for either defects or enhancement requests. If you are 
a committer than please add the labels "bug" or "feature". If you are not a 
committer please make clear in the comments which one it is, so that committers 
can add these labels later.
   
   If you are reporting a defect, please edit the issue description to include 
the
   information shown below.
   
   If you are reporting an enhancement request, please include information on 
what you are trying to achieve and why that enhancement would help you.
   
   For more information about reporting issues, see
   
https://github.com/apache/incubator-openwhisk/blob/master/CONTRIBUTING.md#raising-issues
   
   Use the commands below to provide key information from your environment:
   You do not have to include this information if this is a feature request.
   -->
   
   ## Environment details:
   
   * local deployment, ubuntu 16.04   
   * Docker version 17.05.0-ce, build 89658be
   
   ## Steps to reproduce the issue:
   
   1.   post build 
   2.   run 'sudo ansible-playbook -i environments/local openwhisk.yml'
   3.   
   
   
   ## Provide the expected results and outputs:
   
   ```
   Deployement should be successfull and could see may dockers runnig
   ```
   
   
   ## Provide the actual results and outputs:
   
   ```
   fatal: [172.17.0.1]: FAILED! => {"changed": false, "content": "", "failed": 
true, "msg": "Status code was not [200]: Request failed: <urlopen error [Errno 
111] Connection refused>", "redirected": false, "status": -1, "url": 
"http://172.17.0.1:10001/ping"}
   
   ```
   
   ## Additional information you deem important:
   * the controller docker is not starting - it is showing restarting and thats 
why its not connecting
   * donno why it is not starting now earlier it was starting fine
   *curl http://172.17.0.1:10001/ping
   curl: (7) Failed to connect to 172.17.0.1 port 10001: Connection refused
   :/tmp/wsklogs/controller$ sudo docker exec -it 90b502b8fbc4 bash
   Error response from daemon: Container 
90b502b8fbc42028cea1ef3759a28101cbf3de88a82dd6526f45d7bfd9c07057 is restarting, 
wait until the container is running
   *Controller log
   [2017-05-19T08:36:45.524Z] [INFO] Slf4jLogger started
   [2017-05-19T08:36:46.049Z] [INFO] [??] [Config] environment set value for 
consulserver.host
   [2017-05-19T08:36:46.052Z] [INFO] [??] [Config] environment set value for 
whisk.version.date
   [2017-05-19T08:36:46.053Z] [INFO] [??] [Config] environment set value for 
whisk.version.buildno
   [2017-05-19T08:36:46.054Z] [INFO] [??] [Config] environment set value for 
consul.host.port4
   [2017-05-19T08:36:46.057Z] [INFO] [??] [Config] environment set value for 
port
   [2017-05-19T08:36:46.061Z] [INFO] [??] [WhiskConfig] reading properties from 
consul at 172.17.0.1:8500
   [GC (Allocation Failure) [PSYoungGen: 34292K->2528K(34304K)] 
38031K->12261K(76800K), 0.0306409 secs] [Times: user=0.02 sys=0.00, real=0.03 
secs]
   [GC (Metadata GC Threshold) [PSYoungGen: 9960K->2528K(66048K)] 
19694K->13671K(108544K), 0.0110149 secs] [Times: user=0.01 sys=0.00, real=0.01 
secs]
   [Full GC (Metadata GC Threshold) [PSYoungGen: 2528K->0K(66048K)] [ParOldGen: 
11143K->9550K(39424K)] 13671K->9550K(105472K), [Metaspace: 
21005K->21005K(1067008K)], 0.0483413 secs] [Times: user=0.03 sys=0.01, 
real=0.05 secs]
   [2017-05-19T08:36:48.981Z] [ERROR] [??] [Controller] Bad configuration, 
cannot start.
   [2017-05-19T08:36:49.002Z] [ERROR] connection pool for PoolGateway(hcps = 
HostConnectionPoolSetup(172.17.0.1,8500,ConnectionPoolSetup(ConnectionPoolSettings(16,0,5,32,1,30
 seconds,ClientConnectionSettings(Some(User-Agent: akka-http/10.0.2),10 
seconds,1 
minute,512,None,<function0>,List(),ParserSettings(2048,16,64,64,8192,64,8388608,256,52428800,Strict,RFC6265,false,Full,Error,Map(If-Range
 -> 0, If-Modified-Since -> 0, If-Unmodified-Since -> 0, default -> 12, 
Content-MD5 -> 0, Date -> 0, If-Match -> 0, If-None-Match -> 0, User-Agent -> 
32),false,<function1>,<function1>,<function2>))),akka.http.scaladsl.HttpConnectionContext$@2bb0c54e,akka.event.MarkerLoggingAdapter@5d033e47)))
 has shut down unexpectedly
   
   
   
 
----------------------------------------------------------------
This is an automated message from the Apache Git Service.
To respond to the message, please log on GitHub and use the
URL above to go to the specific comment.
 
For queries about this service, please contact Infrastructure at:
us...@infra.apache.org


With regards,
Apache Git Services

Reply via email to